WD2Go Connection Failed (or not) and other issues

I have had my first MBL replaced due to intermittent loss of Dashboard and failing to ShutDown upon request.  The brand new replacement from the retailer seems to be functioning much better although I have encountered issues with WD2Go ipad app today.

Just in case the circumstances ring any bells with anyone I have set out what I have done so far.

  1. Hooked up the MBL to my home network with no internet connection. No setup software used. (An immediate update of firmware wrecked the first MBL so I did not want a repeat).  Double checked that automatic updates is disabled

  2. Checked out the status of the MBL, firmware is MyBookLive  02.32.06-006 : Core F/W, turned off itunes server,  turned off twonky server, set up the MBL with a static IP address.

  3. Checked out the Dashborad functionality, all seemed well

  4. Transferred some files from the computer to MBL for back-up, including photos and music, about 61Gb.

  5. Paired up the ipad with with the MBL using the ipad WD2Go app.  Access over the local network worked very well. Was able to view photos, stream music, view word and excel files, pdf, on the ipad. (Some word docs gave a message  “Unable to read document An error occurred while reading the document” others displayed perfectly.  Cannot work out why some docs are affected and others are not.  Anyone any ideas?

  6. Turned Twonky server and iTunes server back on to check that twonky worked with my blu-ray player’s dlna server, and that the iTunes server served up music to my computer’s iTunes player. All seemed OK.

7.  Tried using ipad WD2Go app and encountered “Device Offline, device is inaccessible” or something like that. Went into the Dashboard > Settings > Remote Access and it showed

Connection Status: Failed

Cannot establish remote access connection. Make sure you are connected to the Internet. (Error 31520)

All devices ipad and computer on my network had maintained good access to the internet including the MBL as this checked out in Dashboard > Settings > Network

  1. Turned off twonky server.

  2. Although the dashboard still showed “connection failed” even after trying to reload the web page to update the dashboard I was able to view photos on the ipad and other files.  Shortly afterwards the dashboard did update to show

Connection Status: Connected

Port forwarding connection established.

So is this just a coincidence or is there a conflict between WD2Go and Twonky server,  or is there another explanation maybe something amiss with my setup?

I think there was a problem with the wd2go app, but it should be fine now. 

I decided to enable twonky server and I had no repeat of issues accessing WD 2Go. As others have posted WD2 Go went down around the time I was having problems. I think that must have been the cause of my problems.