WD2500AAKX / WD500AAKX / WD10EZEX (None of them install)

P8Z77-V LX2

Win7 Pro

Disk 0 SanDisk SSDP256G

Disk 1 WD2500AAKX

Sequence of events:

  1. Removed healthy WD2500AAKX (secondary) to upgrade to new WD10EZEX (secondary) 

  2. Connected to SATA 6Gb port

  3. Booted, entered Bios showed DVD, SSD and WD10EZEX.  Checked boot sequence ok. Confirmed Sata Mode=AHCI

  4. Windows starts up and notifies “Installing device driver software”

  5. Windows notifies “Device driver software was not successfully installed”

  6. Shows in Dev Mgr as unknown device but with WDC Model Name. 

  7. Automatic and manual driver search failed.

  8. Checked cables etc. and reboot.  Same outcome

  9. DOA?  Removed WD10 and tried on another machine.  Installed, not DOA. 

  10. Checked device driver details (disk.sys and partmgr.sys) matched on both machines.  Identical

  11. Checked SSD device driver details.  Identical.  Drivers present.

  12. Thinking time (recap: removed working WD2500 and replaced with working WD10EZEX but drivers now don’t install)

13. Replaced the original WD2500 and tried that - now get the same driver software problem.

  1. Pulled healthy WD500AAKX (secondary drive) from other machine - same problem.

  2. Machine is working fine with the SSD but a bit risky running one drive without backup!

*ONLY* thing that changed was the hardware: WDC drive model.   

Any ideas, anyone?

*/EDIT typos/*

Was the original WD2500AAKX that you removed also set to AHCI mode in the BIOS? If not, and you changed it to AHCI then Windows most likely doesn’t have the drivers for the AHCI controller and you have to change it back to what it was originally set to.

You confirmed that the drive works in another system so it can’t be the drive. Try choosing “uninstall” for the driver listing (check the option to ‘delete the driver software for this device’) and then shut down the computer and unplug the drive. Boot the system up without the drive attahced. Then shutdown and re-attach the drive, power up and see if the driver installs this time.

Thanks for the suggestions. 

“Was the original WD2500AAKX that you removed also set to AHCI mode in the BIOS?”

Yes - the Bios has one SATA Mode button, it’s always been set to AHCI. 

Can I repeat something - I had the WD2500 running in the machine for over 18 months.  I took it out, put the WD10 in and did nothing else and since then no go.

On the second suggestion that’s now been done several times now across all three of the WDC drives that I’ve tried to install in that machine. The driver software doesn’t load.

Any more ideas would be really welcome…