WD20EFRX corrupt data when copying multiple file onto the disk

I am using the WD20EFRX with a dock from century (CROSU2F) on my laptop (Lenovo T400, running Win7 Pro). When I try to copy multiple files from my computer to the disk, the files always end up corrupted. The CRC and MD5 of the original file were different from the file on the disk. The dock works fine with my other harddisk (WD6400AAKS). I’ve tried the WD20EFRX with the dock on other computers running Win7, no problem at all.  I have removed utility like Teracopy and antivirus, which doesn’t help. I also tried to uninstall the USB Mass Storage and USB Controllor driver, the problem presist. 

The file looks fine, if I copy them one by one(copy the first one and wait until the transfer complete before starting the next). I tested transfering in XP mode on my computer, it gives around 80% of correct files.

I don’t know what else I would try to solve the problem. Can anyone please help or give me some hints?

To verify if the WD Red has any problems, you can try connecting it directly to a computer and running a DLG test. Also note that external enclosures or docks are not supported officially by Western Digital. You can try contacting the dock manufacturer to see if they have suggestions or maybe some of the other WD community users can give some advise.