running windows 7 64bit

gigabyte 720d-us3 mobo

this hdd is being detected as 931.53gb

2.0tb hdd limited to sata 3.0gb from pin 5-6 as mobo is on 3.0gb

any help would be apprecitated as this is a replacement for my other 2tb which was 3.0gb which worked fine

untill the bad sectors (BAAAHH)

I suspect that a bug in Gigabyte’s Xpress Recovery BIOS has incorrectly truncated your drive after the BIOS wrote a backup copy of itself to a HPA.

See this thread for an explanation and solution:

well ive tried that hdd tool

HD Capacity Restore Tool

LAME… doesnt even pickup any drives

WD tools is useless as well so im thinking is time to bring the drive back and get a working one…

i didnt buy a 2tb hdd lasttime so i could get it replaced with 2tb which is only 1tb which needs to be fixed by programs to get it to 2tb because WD is to lazy to bring out tools that work…

this will probably be the last time  i buy WD maybe till i upgrade the mobo but then again screw this trouble, i bought a asrock sata 3 card as well to see if it would pick it up but NO… still same size WD you got some explaining to do …  FAIL

You are unfairly condemning WD. Your problem is caused by a bug in Gigabyte’s BIOS. Gigabyte motherboards have been trashing 1TB+ HDDs, from all manufacturers, for quite some time now. In fact I frequently answer questions on this same subject in many different forums, including Seagate’s.

I suggest you try HDAT2. It will definitely fix your problem. It boots from a CD or USB stick, so it is not being hampered by Windows, as is the HDD Capacity Restore Tool.

If you try another drive, then Gigabyte’s BIOS will trash it as well … if you make it the first drive in your boot order. Ironically your “damaged” drive is now immune to the BIOS disease. This is because BIOS will see the backup copy of itself, and it will therefore not need to touch the drive again.

sounds strange that i have 4 hdd sata 2 drives working fine and i get 1 new drive sata 3 and all of a sudden its gigabytes fault.

i btw have 

2 x 500gb drives 

1 x 1tb drive

1x 2tb drive 

all working from day 1 i got the mobo 

tell me whos fault it is…      :robotsurprised: stop playing the blame game and make drives that work !!

–hold on they did, they just fudge something up. thank for the rma !!!

and they are a mix of seagate and wd