WD20EARX third drive failure in about 1 month

I originally bought a WD20EARS in December 2011 and it was running decently until around June when I noticed it was running slower than normal.  I downloaded and installed the DLGDIAG software and the SMART quick test failed with

Quick Test on drive 2 did not complete! Status code = 07 (Failed read test element), Failure Checkpoint = 97 (Unknown Test) SMART self-test did not complete on drive 2!

So I requested an RMA and got all the data moved to the new drive.  I ran the diag on the new drive when it came in and it passed then after a week or two it started doing the same thing as the first, so I ran the diag on it and got the same smart failure message.  Opened a new RMA, the newest drive arrived last week and I spent the weekend copying data over and it would not copy faster than 3.0MB/s so it took all weekend to do the copying, it did seem like it was the old drive causing it to go slow as the newest drive passed diags and I could copy to it faster from another drive in my PC.  So now I have removed the old drive and have just my primary drive, and this newest replacement in it.  Now I’m getting the same error as I have on the previous 2 drives and access to the drive is slow. 

It just seems odd that I’d have 3 drives fail with the exact same issue and symptoms within such a short time frame.  Any suggestions?

3 drives yeah that does seem odd. Have you had power failures, or a shotty PSU mabey? How new is your other hardware?

No power failures at least with the most recent drive, it was on all weekend copying the data over.  The other hardware is probably about 2 years old but haven’t been having any other issues other than this 1 drive out of the 2 in the system.  I called WDC and they are going to send me a 2.5TB drive in hopes that it will work better.  When I run the extended diag test it’s saying too many bad sectors, so I’m at a loss as I can’t think of anything else that would cause it.

biostar ta990fxe motherboard

AMD Phenom II X6 1055t


700W PSU

1.5TB Seagate drive

2TB WD drive

DVD Burner

Geforce GT 240 graphics

Prolly something in your system missing the drives up. Could be a faulty SATA-cable, check that first!