WD20EARX Tests Good but "Freezes" in Windows


#1

Been pulling my hair out on this the past 24 hours. Here’s what I know.

  1. When this drive is in my Windows 10 x64 Gaming PC, windows behaves badly. Depending on how I have the SATA config (AHCI or RAID) it behaves slightly differently. As RAID basically I loose certain access to certain windows applications for anywhere from a couple minutes to indefinitely. Looking in the Event Viewer I get event codes 129: Reset to device, \Device\RaidPort0, was issued. From iaStorAC. Then either under AHCI or after I removed the Intel RST drivers, after I attempt to log into windows it just sits there at a grey screen for minutes, I give up, power off. If I pull the SATA cable to this EARX drive (also contains a Crucial SSD (boot drive), a Seagate 2.5" 2TB drives and a WD20EARS) the system behaves properly. Put the drive back into service, back to the aforementioned behavior. I’ve also swapped SATA cables and the last time, tried the SATA port my BD drive was working on (moving it to a known working SATA port). Same issue. So without a doubt, there’s something specific to this drive.

  2. I’ve tested the drive on short random, short and long with one tool when it was in a USB enclosure on another PC (Win10 Pro x64). All tests pass, no errors.

  3. Even better, I tried Data LifeGuard via the Hiren’s WinPE boot drive in the PC I’m having the problem. In the SATA port and such from the last full windows boot attemp and it passes the tests there. If I open explorer, I can view the contents of the drive, etc… so it doesn’t appear to be a BIOS/UEFI issue (I am on the most recent bios for the MB regardless). So the drive appears to be just fine everywhere else, except within this Windows 10 x64 Home install.

Other pieces of info… the drive is currently formatted as exFAT. But again, accessible via my Win10 pro setup via a usb enclosure and through the WinPE environment of the hirens cd on the pc displaying the issue.

Anyone have any idea of what’s going on? I don’t even know how to google my way around a solution here.

Unrelated (but not): My brand new WD Red 100EFAX that hasn’t even been powered on for 10 days in my NAS just started dying yesterday. Audible clicks, ATA errors and pending sector issues. (I’ll take your pity). :slight_smile:


#2

Spoiler alert: Reformatted it from exFAT to NTFS inside the WinPE Hiren environment and Windows cooperated.


#3

exfat isnt a robust file system… its very easy to loose files if you eject the drive without safely removing it first in software