WD20EARX is not formatting

Hello,

I have WD20EARX drive that get missing when formating.

When I first put drive in my PC it was formating fine. But when attempting to copy files on the drive, the transfer lasted a few seconds before transfer stalls and then drive is missing from ‘My Computer’. After restart drive is back but the same problem back too.

I’ve tried almost all(different cables, different partition sizes, different sata ports, and tested the drive for faults whit Data Lifeguard Diagnostic for Windows ) - it not helped. All drivers is up to date.

Then I reinstall my OS by cleaning my OS drive. Now I can’t even format my drive. But still Data Lifeguard Diagnostic for Windows  shows - drive is OK :angry: All others drives working perfecly

   
   
   
   
 
Test Option: QUICK TEST
Model Number: WDC WD20EARX-00PASB0
Unit Serial Number:  
Firmware Number: 51.0AB51
Capacity: 2000.40 GB
SMART Status: PASS
Test Result: PASS
Test Time: 18:20:28, September 23, 2011

   
 And what I get after failed formatting:  
Test Option: QUICK TEST
Model Number: WDC WD20 EARX-00PASB0
Unit Serial Number:  
Firmware Number: 51.0
Capacity: 2000.40 GB
SMART Status: Not Available
Test Result: FAIL
Test Error Code: 08-Too many bad sectors detected.
Test Time: 18:23:35, September 23, 2011

My PC specs:

OS - Windows 7 Ultimate 32bit

MoBo: Gigabyte GA-970A-UD3 AM3+

Proc: AMD Athlon II X3 460 3.4GHz
Video: Sparkle 440GT 1GB 128-bit GDDR3
RAM:  Kingston 2 x 2GB

HDD:  320GB Samsung HD321KJ - My OS drive

           500GB Samsung HD501LJ

           750GB Samsung HD753LJ

         1000GB Seagate Baracuda ST31000528AS

         2000GB Western Digital WDC WD20EARX-00PASB0 - problem drive

So, what to do? Ask to replace drive?

Replace it!

I just bought one of these and have the same issue weird i wonder if ther eis some flaw with this particualr model. Never had a DOA (well - so many errors) on a new drive before…I think I will RMA it  too

Hi,

Sounds like a similar problem I’ve got  with 2 WD30EZRX (see here- http://community.wdc.com/t5/Desktop/WD30EZRX-shuts-down-comes-back-again/td-p/258642))

WD support said it was because my motherboard didnt support SATA 3, even though my board has 4x SATA 2 and 2x SATA 3.

They also ignored the fact I’d tried the drives on an Adaptec 6405e that has 4x SATA 3.

Trying to get to the bottom of this is costing me more in time than the drives are worth.

Bought a couple of 2TB Seagates now. Had enough messing around.

Hope you eventually find a solution