WD20EARS strange firmware and no SMART data


#1

Hi,

I just bought 4 x WD20EARS-00MWVWB0 drives and I’ve just noticed that one of the drives are different to the others.

3 drives has the firmware: 50.0AB50

1 drive has the firmware: 09570115

The 50.0AB50 drives all show health status, temperature, power on count/hours and display SMART data and have

Standard: ATA8-ACS | ----

Supported Features: S.M.A.R.T., 48bit LBA, AAM, NCQ

The 09570115 drive, does NOT show health status, temperature, power on count/hours nor SMART data and have

Standard: ATA/ATAPI-7 | —

Supported Features: S.M.A.R.T., 48bit LBA, APM,

50.0AB50 Drives:

09570115 Drive:

369i8D7408D6699FFA59

The weird drive seems to be working, but I’m thinking that I should return it as it seems to be dodgy and maybe have some pre-release firmware and should never have made it into the market.

Any suggestions?

Cheers

Martin


#2

Try using the smartctl util in Linux to enable SMART data collection since the drive is reporting that it supports it. The ATA-7 bit may not support reporting the 512B/4096B sectors and may just say 512B but I’m not 100% sure on it. I believe that is ATA-8 that allows it.


#3

I have a nearly identical situation. Four drives, three with the 50.0AB50 firmware, one with 0956.  

smartctl will not save vendor specific data on the drive with the older firmware.

My question to WD is this: Is there a way for us to update the firmware on these drives?  

The software section of the web site shows several links to monitoring tools and the like, but no firmware update that I can see.

Regards,

Scott


#4

I think drive makers have shied away from publicly access to firmware updates. Last one I found was an OLD OLD one for my 730MB Western Digital Caviar drive. And that was many years ago.