WD2003FZEX possibly failing (7 months old)?

Hi there
I purchased this drive (WD Black, 2TB) November 2016.
I have noticed it seems to make a lot of noise when accessing files / opening programs (well any activity on the drive). I usually expect to hear this from an old drive. I have ensured the drive is not fragmented.
So just last week I was updating a game in Steam and for the first time I got a disk write error. I eventually just left the update and did it the following evening - it gave one more disk write error, but I resumed it and it finally finished updating.
Yesterday I tried installing a new game on Steam and yet again another disk write error. Today I have tried to install the game again, but it seems to write a bit and then give an error.

Is this drive failing?
I chose the WD over Seagate (which I think was less than half the price of this drive) as I’d read reviews and all and with the better warranty and so on the WD seemed the better choice in the long run. I’m not sure if it is at this point. I actually have two 1TB seagate drives, one about 7 years old, the other about 10 years old and they do not make this noise.

Please can you advise me on what I should do. I don’t believe this is a bad hard drive - maybe mine is just unfortunate. Or maybe it’s just meant to make “accessing noise”, but then there’s the write errors I’m getting… hmm.

I live in South Africa.

Kind Regards

Hello there,

Test the disk for errors using Data Lifeguard Diagnostic:

http://downloads.wdc.com/windlg/WinDlg_v1_31.zip (Windows)

http://downloads.wdc.com/dlg/dlgdiag_5_27.zip (DOS)

Hope this helps.

Did the extended test and it passed. But still getting disk write errors and a lot of noise.

OK, my system disk was using MBR and this disk is using GPT. Is that an issue?

I just changed the system disk to GPT today, but I can’t tell what the result is quite yet.

Anyone able to confirm the above?
ie. Using MBR system disk and secondary (storage) disk is GPT is problematic?
Wasn’t using UEFI but Legacy - system does support UEFI. I did change to UEFI after making the system disk GPT.

So far, now that system disk is GPT as well, it seems like things have improved, but I’m still testing.