WD2001FASS 2TB drive not detected on Asus P5B Delux WiFi


#1

I bought 2 new hdds both from western digital. a 600gb velociraptor and the 2tb wd2001fass.  I pulled all the old hdds out ( will worry about backing them up later).  Installed the 600gb drive as the boot drive, got win7 x64 installed and everything was working great. 

When I tried to install the 2tb drive it is not detected in bios or windows.  I have tried changing the sata port, using the jumper to force 1.5gb/s.  I also have an external usb adapter for sata drives and it wont load with that either (though it does spin up).  Just to make sure that adapter still worked I through one of the old drives on and it loaded right up in windows.  I also tried disconnecting the sata cord (since it causes the boot to freeze when auto detecting ahci drives) and connecting it once it gets past that part.  When I go into disk management in windows it does show that drive but when I try and initialize it, it says in cannot due to an i/o problem. 

I have this all setup with a asus p5b delux, in the past I have had little issues when using different hdds but one of the fixes I had tried with this drive fixed the problem with the others.

  Any help is greatly appreciated and if I left out any details that will help solve the problem, please let me know.


#2

tonight I tried using the WD data lifeguard diagnostic (just to see if that would find it), the dos version on a cd booted up but did not show this drive, the windows version is for x86 so that didnt load. There are no firmware updates for the hdd avail from wd, they also do not have any drivers that I could find. The drive is not formatted, cannot get bios to find so it is not available in the windows 7 cd boot up. Its odd because I was able to get it to show up in windows as an unknown drive. but I have it hooked up/loose in the case and was holding the drive through booting the system up and windows starting up and at no time do I hear/feel it spin up, the only time Im able to get it to do so is with the usb adapter.

If I’m missing something any help is greatly appreciated. As of now Im thinking something is wrong with the MOBO not supporting this drive or bad drive. I did try the usb adapter on a different pc and got the same results, but I have not tried opening up the wifes comp to test it yet.

Also, I have been trying everything in both bios IDE and AHCI modes, with and without the 1.5gb/s jumper and with and wihtout the velociraptor hooked up and have been changing sata slots.


#3

Is your drive configured to Power Up In Standby (PUIS)???

See this thread:
http://community.wdc.com/t5/Desktop/WD3200AAJS-320GB-HD-not-recognized-until-accessed-from-DOS/m-p/24836

Does your drive still power up in the USB enclosure if the SATA data cable is disconnected?

Be aware that Windows may be detecting the USB-SATA bridge chip in the enclosure rather than the drive behind it.

You may like to compare how Microsoft’s UVCView utility sees the enclosure with and without a drive installed:
http://www.users.on.net/~fzabkar/USB_IDs/UVCView.x86.exe

BTW, I believe some drives will not power up until they detect a SATA controller. I have no idea if your model is one of these.


#4

There is no jumper over pins 3-4 (says those pins are to enable PUIS on the hdd label)

If there is something set in the drive firmware it would have been done from factory as I have not gotten this drive to detect in bios or windows.  As of now I think when it did show up in windows it was just the usb ata bridge that was detected.

I cannot remember what I did to get it to spin up with usb adapter, trying to do it again has not worked.  the adapter I have has the power and sata cable all together so I cannot test with sata disconnected. 

I had everything setup in ahci, but formatted back to ide so there was no question about that.

I cannot find any other people that have had any problems getting it to detect, on newegg the reviews are either good (it worked) or bad (doa).

When it did spin up on usb adapter it spun for 5-10 serconds that made click and stopped.


#5

Contacted Asus earlier today just to make sure there was no known issues with this drive and the P5B Delux, there were none.  Contacted WD and after explaining each thing I tried I was told the drive was bad and they will RMA it.


#6

I have an Asus P5QL motherboard but I think my problem is the same.

What I did was I read  that your main boot drive has to be on pins 1 or pins 2 on your motherboard.  Then your storage drive that isn’t booting has to be on pins 3 or pins 4.  Try that out and let me know if it works.


#7

Also, did you try another sata cable?  I/O issues can sometimes be the cable.


#8

Received a replacement drive in the mail today directly from WD, Installed the drive, started the system and it was immediately recognized by windows, formatted it and good to go.