WD15EARS not booting, but powers up

Hi all,

I am sorry if I missed it somewhere, but I could not find a solution to this. I have a 1.5TB internal HDD which was set up as a secondary drive (not bootable) but had an old install of Windows 7. My primary drive has Windows 8. Today my primary drive would not boot, so I unplugged the computer, unplugged the secondary drive and booted the primary fine. Upon reconnecting the secondary drive, it would not get recognized by computer.

I took it out and plugged it into USB enclosure and it would get recognized, assigned a drive letter, but upon clicking it would tell me that the drive needs to be formatted.

I ran WD tests and the drive checks fine.I have rather important data on it and it seems like that it is MBR or partition info corrupted, because the drive is powering fine, makes no crazy sounds.

I want to make sure that I do not do something crazy rebuilding partitions or MBR which would compromise data, so I thought I would ask someone for advise.

If it is partition or MBR recovery, what is the best software - paid or free.



Hi there and welcome to the WD community.

I have not tried this, but lets see if another user can share some tips and information on this matter.

install hard disk sentinel and check health

And use file scavenger or another tool to recover the files