WD15EADS-00P8B0 Really slow? Or am I just crazy?


#1

Hello.

Bought a Western Digital 1.5TB Caviar Green a on the 30th of November from Amazon, shipped to my doorstep, mounted, installed… then began the process of doing full partition and formats on the whole drive.

Running Vista x64, which has generally worked well enough on my system (Intel Core 2 Duo E8400, 8GB DDR2 RAM). The whole partition process took about a week, running in the background as I used my computer, using the “Disk Management” tool, under “Storage” in the “Computer Management” program. Four primary partitions were created, doing a full format (as opposed to a quick format), the first three at  300 GB, and the rest of the space allocated to the fourth partiotn. The fourth partition was formatted using diskpart in command prompt, as the Disk Management tool didn’t want to make the fourth partition a primary partition.

Anyhow, during this time, I didn’t do any read or writes on the drive while it partitioned and formatted. Once it was finished, I then began to copy over some anime. It said it’d take some ungodly amount of time to copy over 24GB (somewhere above 20 hours, iirc)… So I cancelled.

I then copied over a few files, and found them hardly accessible. After some fanangling, I set up a test.

I first copied over an episode of Spice & Wolf, mkv container, h.264 encoded, weighing in at about ~230MB. Copied over in about 8 seconds. Then, I went to -play- the file by double clicking it. The default program set for this is Media Player Classic. Once I double clicked it, I used a stopwatch…

Two minutes, and twenty three seconds passed by , and it finally started playing. Of course, at the beginning, it was hardly buffered, and had a few stops… and even as it continued to play, it had a 30-50ms jitter, meaning that the read/write of the video was off, as it should be around 3-6ms in my usual experience on this computer.

I would note that something like 5-15 minutes later, when I accessed it, it played normally.

I ran an error check using DOS WD Lifeguard tools, the quick scan option, and no errors were found.

This leads me to question if the drive is at fault… I’m pretty decent when it comes to computers and troubleshooting, but this would be my first drive I’ve ventured with past 320GB.

Now, I can -still- return this drive to Amazon… but I want to hear other thoughts or suggestions first. Is this the sort of thing that this drive has been known for?


#2

Could you check the Vista system log and see if there were any disk related errors? Also it’d be good to check what DMA speeds your drives are set at (if in ATA/IDE mode)…with enough errors Windows will keep reducing the speed grade until the hard drive is working in some PIO compatibilty mode. Real slow then.

I had something similar happen last year and it appeared to be a cable problem. The weird thing is all I had to do with take the cable out and reconnect it (or connected it to a different SATA port) and the recurring errors were gone. I’m still not convinced that was it but there are limits to my patience when troubleshooting hardware/software problems.


#3

@ arpuress:

Well, there seems to be nothing in Event Viewer or Problems History. All ATA/IDE Controllers (Though this drive is SATA) are set to DMA, and all SATA controllers are set to DMA as well. As for the Cable problem… funny enough… originally I had run the WD Lifeguard Tools Diagnostics in the Windows environment, and I got a cable error. This caused me to swap out three different cables (Had extras from ASUS, I’d like to think that they felt bad for people spending $300+ on a motherboard and gave us a whole buncha crap), all resulting with the same error. However, my main drive, which functions well enough, got this error too. Once I used the Lifeguard Tools in DOS though, it worked perfectly fine… So I don’t think it’s the cable.

Interestingly enough, though… I hadn’t noticed the benchmark tool in vista built into the controller properties dialog.

Essentially, go to Device Manager, IDE/ATA ATAPI controller, then to one of your motherboard’s Serial ATA Controllers, Right-Click, Properties… Then go to one of the Port # tabs (Port 0, Port 1, etc). Right next to the Command Queuing checkbox option is the “Speed Test…” button. Click and test.

Here’s some test results, all using SATA II… measured in Millions of bytes per second:

Drive Name\Burst Speed\Sustained Speed

WD2500KS-00MJB0\118.1\61.0

ST3320620AS\124.5\56.0

WD15EADS-00P8B0\133.9\0.8

The Sustained Speed number for the Caviar Green 1.5TB (WD15EADS-00P8B0) is quite shocking… not even a full megabyte. I did some more retests, and the first two generally maintain the same numbers, within a margin of one or two whole numbers… while the WD Caviar Green (the last one) generally hovers somewhere between 0.1 and 4.2… and it spiked once to 10.1.

Again, I’ve never used these benchmarks before… but if these ARE accurate, then there’s definitely something wrong.

Taking anymore suggestions… I’ve linked this thread in my support request, thank you once again arpuress!


#4

yes there seem to be a problem with WD15EADS-00P8B0 but WD dont seem to be willing to replace them so all we can hope for is a FW update until then you will have to live with a very slow HDD or hope the store will take it back


#5

Hmmm, this sounds very similiar to my issue.  What was your resolution?  RMA the drive?


#6

I’m getting pretty much the same from a brand new WD20EADS, which seems to be the 2TB version.

I bought this one because I’d read so many bad reviews on the Seagate and Hitachi drives, with people having to RMA them, but it seems Western Digital are just as bad if not worse. 

I would prefer a drive to simply fail early in its life than have a uselessly slow drive with the hope there might be a firmware fix from the manufacturer.

Help !!


#7

I have put in a help ticket on this subject.  Hopefully I get a response tomorrow.  I did some decent analysis and cross compares to see that this performance is WAY out of whack.  I am beginning to think it might have something to do with the drives “Intelliseek” feature.  I heard some things about a program called wdidle3 that I might investigate if I don’t get a good answer back from support.  If all else fails I’m returning the drive.  It took me about 20 Hours to transfer 136 GB (38,000 files) of data from my Raptor Drive to this WD15EADS.  1MB/sec is about the speed I was getting.  This is unacceptable in my opinion.  Good to know I’m not the only one seeing the issue.  I’m not sure if the issue is only on writes or if it is also on reads?  I have been looking at data inside the Windows 7 drive speed tests.

-Tony


#8

I am an A+ certified tech who happened to buy this particular drive for home use. I also have had the same problems with the drive being slow. I of course overlooked the most obvious thing…If you get into device manager and click on that hard drive. In Windows Vista Choose the tab: Policies. When you see the 2 options click on  Optimize for performance. Click OK and it will prompt you to restart the computer. Now i have this in a usb enclosure and this made my speed go through the roof…hence normal operation. I don’t have XP on my PC right now but it should be pretty similar in the steps. I hope this helps! Good Luck!


#9

It looks like I got the same problem too.

I bought couple of WD 1.5 TB external drive (Elements) (WD20EADS-00S2B0) and it was fine when I was backing up my stuff to it through DVD - then out of the blue the whole drive just died. I took it out of the drive enclosure, plug it in using E-SATA and thanked god that it still works, only to discover incredibly slow speed at reading/copying/transfering anything. It would take a GOOD 10 MINUTES to transfer 1.3 GB file. On my other drives (WD non-Green Power Crap)  it only took 40 seconds!!!

SO [text deleted]  IS WRONG WITH THIS?I REALLY WANT TO KNOW. NOW NOT ONLY IS MY EXTERNAL HDD NOT WORKING, TAKING IT OUT IT IS STILL A DUD. IT REALLY, REALLY MAKES ME ANGRY WD IS SO IRRESPONSIBLE AT HANDLING THIS. 


#10

AT2ECW,  I tried what u describe, it still does the same thing. I think the WD hardware is just faulty.


#11

I have exactly the same problem here. This performance is just not acceptable, its absolutely awful.

I tried to debug the problem and found that irregularly the drive just jumps to 100% load according to windows7 resource monitor. Funny thing is, an I/O queue builds up but the actual activity on the drive is negligible. Eventually it gets so bad that even downloading a file from the web is slowed by the drives performance :dizzy_face:

As i use this drives in my HTPC its really getting ridiculous. The SSD i use for the OS is out of the question for timeshifting as it simply is to small, so i get freezes when watching tv all the time and the spare drive i have right now is a rather noisy seagate drive that also is not exactly fun to have in a htpc.


#12

I’ve noted similar problems with my new ED15EARS drives.  I’m still attempting to track down if the “advanced format” is causing me issues or not.  In one machine, the drives seem to move fine individually, getting 76MB/s transfer rates.  in another, they slow down to about ~10MB/s.  These aren’t the painfully slow speeds that others are describing, but I’m wondering if they might be related.  The 64k buffer of the EARS series might stave off some of the problem, but not all. Additionally, I haven’t fully tested if it was related to the RAID1 setup I initially started these drives in.  Its possible that might have something to do with my particular problem.

I disabled the power saving features of Win7 (i.e.  Disk sleep after 20 minutes) though it seems odd that would cause any problems immediately.  And…if the drive is transfering data…then it wouldn’t exactly be idle.  That could be a problem with either the HDD reporting or windows software detecting.

Also, since it is an advanced format drive, I was concerned that perhaps the factory “alignment” of the sectors wasn’t done correctly.  I’ll have to research the WD tool to verify, but it would be nice if Win7 could tell you that outright.

The only other obvious differencse are that the machine which is slower is an ICH9R system running 64bit Win7, while the “fast” machine is ICH10R system running 32bit Win7.

Has anyone run the alignment utility on a newer OS to see if everything is in order?  Is there any reason a “Quick” format might cause issues while a standard format would not?  In my case, it seems that if one of the alignments was out of sync with the other, then a RAID would suffer problems.  of course, as of now neither windows nor the intel RAID software report problems, but then again they might not know how to deal with alignment issues.

I also wonder if the factory might have applied the advanced format alignment to some of the EADS drives…and therefore screwed them up as well.

I’m sure WD is aware of the problem, the question is just how deep it runs, and whether or not they are scrambling to resolve it.  If we are a minor subset, they might consider it worth the cost of RMAs or lost customers…but if if is a larger problem with their Advanced Format implementation, then they might have a bigger problem on their hands when all drives shift to the new format.

My initial research into the problem also took me to Microsoft Windows forums, and users reporting the problem as a major Win7 bug.  I will have to go back and look at some of the posts to see if WD drives are involved.

EDIT:  Having placed this drive in the other machine, my speed problems appear to be tied to their usage in RAID.  Peformance is adequate when the drives are used standalone.

Sorry, I realize this doesn’t exacly help folks, but I thought I would share my results

It is aggrevating to know that WD intentionally disables settings on a perfectly good drive to force you to pay more for their “RAID”/Enterprise drives.  Why can’t us HTPC users with minimal performance demands take advantage of the best GB/$ ratios AND get a drive that can RAID properly?


#13

I am having similiar problems with this disk in a Linux system.

The disk simply goes to 100% utilisation, with almost no actual io happening, so anything you try to do takes ages.

The iostat utility on Linux shows;

Device:         rrqm/s   wrqm/s     r/s     w/s    rkB/s    wkB/s avgrq-sz avgqu-sz   await  svctm  %util

sda               0.00     0.00    0.00    0.00     0.00     0.00     0.00     7.00    0.00   0.00 100.00

I have 2 identical disks in the same machine, so i am going to try cloning and swapping them and seeing if the problem follows the disk.

Problem disk is;

  Model Number:       WDC WD15EADS-00P8B0

  Serial Number:      WD-WMAVU0046239

  Firmware Revision:  01.00A01

  Transport:          Serial, SATA 1.0a, SATA II Extensions, SATA Rev 2.5, SATA Rev 2.6


#14

yes the 00P8B0-disk is useless, but WD doesnt see any problem with a writespeed at 1MB/sec…

Im hoping for a firmwareupdate for tthis.

 This kind a ignorance from WD wont be forgotten by endusers like me and others I think…


#15

Yesterday I swapped the disks by cloning the problem disk (using ddrecover) onto the 2nd disk and then swapping them.  After a short time the problem re-occurred on the 2nd disk, confirming that the problem is the disk not something in the system or software.  I have removed the fautly disk and after 2 months of pain the system is now running perfectly. 

So, just to clarify, the symptom was that the system suddenly ran very slowly for periods of 5-15mins every few hours.  Further examination showed that the disk was doing very little IO, but reported 100% utilisation.

The two disks are identical, purchased aty the same time from the same supplier, both

  Model Number:       WDC WD15EADS-00P8B0

  Firmware Revision:  01.00A01

One disk had a fault where it intermitantly ran slowly, the other is fine.

Hope this helps somebody.

WD, do you want my faulty disk???


#16

“I bought couple of WD 1.5 TB external drive (Elements) (WD20EADS-00S2B0) and it was fine when I was backing up my stuff to it through DVD - then out of the blue the whole drive just died. I took it out of the drive enclosure, plug it in using E-SATA and thanked god that it still works, only to discover incredibly slow speed at reading/copying/transfering anything. It would take a GOOD 10 MINUTES to transfer 1.3 GB file. On my other drives (WD non-Green Power Crap)  it only took 40 seconds!!!”

I had the EXACT same experience. This is apparently by design. Hopefully someone from WD will make a public statement. This is complete garbage 4k sector bull bleep. I thought my brand new disk was dying, which was bad enough, but to know that now my replacement drive will probably do the exact same thing? hella lame!

I too thought i would give WD a try after buying seagate for years. Monoculture and all that, but this is just a complete atrocity.




#17

i’m also having this exact same issue with my 1.5TB WD hard drive.  it worked great for a few months then i started noticing that it was taking longer and longer to write files to the drive.
sometimes it would take 30 seconds to browse folders in windows explorer
also, when transferring files to the drive, the progress showing time would bounce around.  looking at the drive in hd sentinel, it has no errors, just incredibly slow write speeds.  sometimes it will stay at 1kBps

for the most part, reading from the drive will work fine.  sometimes it slows down.  also, i’ve noticed that when i boot windows (xp), it will sit at a black screen for 30 extra seconds when the drive is connected.  it never used to do this.

i guess i’ll RMA the drive


#18

Maybe you’re experiencing the well known partition alignment problems related to 4096 byte physical sectors of those drives.

Try partitioning the drives with a proper offset (divisible by 8) like described in this discussion:

http://community.wdc.com/t5/Desktop/Problem-with-WD-Advanced-Format-drive-in-LINUX-WD15EARS/td-p/6395


#19

well, my drive is a WD15EADS, I’ve read that only the EARS hard drives have the 4k issues


#20

You are correct that EARS drives are the only Advanced Format drives from WD (at this time).  However, it is possible that the drives are similar enough and prone to the same QA failures.  They might even be made in the same factory where union inspector “Q47” (or something similar, lol) is simply collecting a paycheck and not paying attention.  My WD10EADS-00Z5B1 drive is working fine.  Then again, I didn’t try to RAID that one.  If I had, I might have sent it back too for failure to perform a vital disk function.

Seriously, what’s so hard about just making the drive spin slower to make it green and that’s it?  Don’t muck with other setting that jepordize its RAIDability. Maybe give it more cache so it can peform better on large video writes, thereby taking less time to spin…and kazam…you’ve got a “lower power” drive that can still do its job.  Didn’t all drives used to spin at 5400RPM or less?  Seriously…who lost the recipie for making ice?