WD15EADS-00P8B0 buggy advanced format or what?


#1

I tried a litte C program found at the bottom of this OSNews article on 4096 sector drives on a WD15EADS-00P8B0.

That program writes 1000 blocks of 4096 at a adress multiple of 4096 +  a given offset of 512 bytes. (REQUIRES LINUX AND C KNOWLEDGE TO RUN)

My results are that changing the offset deeply impacts the performance of this drive, when it should not, since this is supposed to have good old 512 bytes per sector and it reports to have one logical sector per physical sector. On my laptop infact the performance are the same with any offset.

On the caviar green instead I ran into a few weird behaviours:

  • offset 0 and offset 8 are fast, any other is like 5 times slower. This makes it look like the drive uses 4096 bytes sectors.

  • sometimes the drive totally froze for a many seconds, just like many user are experiencing. Once it took almost 3 minutes to complete the writes instead of 3 seconds.

It seems that this drive has a partial or buggy implementation of the “advanced drive format”.  I even tried to align partitions to multiples of 4096 but it did not remove the freezes (it might have helped the performance tough).

I am sick of this drive… There is something wrong here.

If there is a way to avoid those freezes I want to know it, else I want an equivalent drive or my money back.

PS: the align tool reports it as a non AF drive too.


#2

4K/Advanced format is only implemented on “EARS” models with 64mb cache…WD15EADS is 32MB cache and it’s the old model without the 4K/Advance format!


#3

well that does not explain the differences in speed when writing 4k aligned or misaligned to 4k blocks.

Many around here there’s someone else skilled enough to test that program too.

I don’t know what they did, but this drive has something wrong. I would really love some official comment on why these drives have performance and freeze problems.


#4

I have two WD15EADS drives that have the same problem. They freeze randomly for every few minutes. After the freeze, they resume working normaly until the next freeze.

I tried 4 diferent OS (WinXP, openSuse 11.1, openSuse 11.2, Ubuntu 9.10) and two different motherboards and the result is the same.

When the disks are linked in linux sowtware raid they freeze and unfreeze at the same time.

Is there any hope to fix this problem?


#5

this thread gives some light to my feeling (really just a feeling I don’t own a EADS disk) that all the newer EADS drives use the internal data architecture also used in the EARS drive (which are labeled  “advanced format”). It would explain all the complaints about the newer EADS drives and especially with the reported problems when you use newer drives in linux based NAS systems.

I haven’t checked your posted linkt to the C programm but your results are exactly the same as what you get when you test a EARS drive.

so, to solve your problems with this EADS drive I would suggest that you follwow the instructions here in the forum how to handle EARS drives. please report your results!

for win XP: does the WD align tool really forbids to be used on a EADS drive? if so you are somwhat stuck. you could try a linux live distribution (boots from cd) and partition your drive with linux and then switch back to windows to format and test it.


#6

I have a 1.5TB WD15EADS with a 64MB cache.  I have also noticed major slowness and freezing.  While WD Align does NOT recognize this drive, it does have a jumper setting on the front for Advanced Format.  I intend to try and reformat using the jumper as soon as I can transfer all my data off of it this week.