WD1200B015 Not initialized Not mounted

Hello, I am trying to get data off of a Western Digital WD1200B015 (120GB) (2005) external drive. Not trying to fix drive for continued use, only to save data (most likely many jpg photos).
The drive does not mount (windows 10), but does spin up and sounds normal. Drive does show up in disk management but only as unknown and not initialized, when attempting to initialize it errors out “system cannot find the file specified” (tried initializing with windows disk management and AOMEI partition assistant free edition. Tried running the free version of Disk Drill and minitool power data recovery 8.5 but it does not show up in either. I did run the Western digital data lifeguard diagnostics DLGDIAG, SMART status is not available and when I ran extended test it completes successfully instantly with current sector 0 of 0.
It was originally used on a old windows laptop and desktop (do not know what windows version) but only tested with windows 10 laptop originally but I have now removed the hard drive from the enclosure and hooked it up directly to my windows 10 desktop however it did not change any of the issues. I tried looking for drivers but didn’t find any, also windows auto driver search came back empty as well.
Any help would be much appreciated, thanks!

Images bellow

[Images removed; they showed serial numbers]

Hey @HalpMePlzWDhdd,

I don’t want to kill your hope buddy but just to save your time, the only option is to contact Data Recovery Company.