WD10TPVT Scorpion Blue 1 TB Failing


My story with the hard drive is that it started having a loose usb cable, with time the loose connection caused cyclic redundancy errors and sometimes it was undetectable and unreadable, after a lot of fidgeting with the cable it worked dozens of times but I fear it caused a lot of wear and tear from this issue. Now my Hard Drive letter (F) does appear, but it doesn’t let me access, it doesn’t give me any properties and it doesn’t show up in Hard Drive Management or CrystalDiskInfo, in fact it stalls explorer.exe and other programs that want to use the drive until I unplug it. I am experiencing a rythmic clicking sound while it spins, it sounds like clicking but it goes in bursts of 3 clicks constantly:


Something like the above pattern.

It used to work fine and it had no physical shock, it never fell or anything, I fear it’s the very bad USB connection that deteriorated my drive. Are my files still recoverable in these conditions? I fear a head crash or worse, but I also think the heads might be obstructed, the disk spins like normal and the light flashes.

Here are the noises it makes:


Hello Thanatos, Welcome to the WD Community. I’m sorry to hear that you are unable to access your files. Have you tried connecting the drive directly to a laptop or desktop? In case that this doesn’t work you can contact any of the WD Data Recovery partners, some of them offer a free evaluation. 


I have, it doesn’t work, it used to falter sometimes and then detect, but now it just makes this abnormal clicking even though no harm was done to it phisically, it was all due to the faulty usb cable :c

Thank you for linking me to the partners.