WD10EZRX not accessible

I have two of the same drives which I am using in a drive dock (and have been for a few months since I got them). One of them, my primary drive for photos, is inaccessible. When I connect the dock and turn it on, Windows 7 acknowledges the connection, the drive powers up, and the drive letter shows up (I assigned letters to both). If I click on the drive, the Computer window takes a while (i.e. the progress bar takes longer than it should). It seems to take longer with USB, and then says the Location is not available and the parameter is incorrect.
If I right click on the drive to view the Properties, it also takes a while and ends up slowing the laptop down and when I attempt to close windows/programs, it leaves part of the window on the screen, and Computer hangs up. I have to kill the talk.

I’ve tried both slots with both drives, and tried the USB (which I was using) and SATA cable/connection with one at a time, and have tried the USB connection on an old laptop. I don’t have a desktop to try.

The Windows Disk Management says it is healthy.  I ran the WD Data Lifeguard diagnostics:

Quick Test does not complete: Status code=07 (failed read test element) Failure checkpoint = 97 (unknown test) SMART self-test did not complete on drive 2

Extended test, 15 min. on same current sector 1952023039
Extended test 2, 16 min. stopped on current sector 1718303743

I have not tried to Repair with WDDL since it says to be careful with that (there is plenty of room on the disk)… I wanted to see whether there is anything else I can try first. This drive is my working drive for my photographs, of which there are more than 30k files. The other drive is a backup, but the files are not converted to the format that is in my Lightroom catalog, and I was in the process of trying to get the files all organized in the same format.

I would appreciate some suggestions to try so I can avoid having to rework these files. What about these:?

http://hddscan.com/  was in another post, and this was in a different forum.


I assume your drive is out of warranty, can’t be RMAed and you cannot immediately clone it to another drive. In some cases just running tests on a dying drive will cause more data loss. My desktop came with a Seagate 1TB that recently started showing a couple of reallocated sectors. It was out of warranty and would not pass Seagate’s SeaTools diagnostics. It was my OS drive so I replaced it with a WD Black 1T (cloned with Acronis). Out of curiosity I decided to try various tools to see if the Seagate could be fixed.

I have been using SpinRite (it is pretty amazing) for many years, but it would freeze at less than 5% into a maintenance run on the Seagate. I was about ready to give up on it when I came across HDAT2 (  http://www.hdat2.com/ ). I used HDAT2 to analyze the disk - I let it analyze the entire disk (24 hours) and it located a bad sector at 001730279. I then ran it in “fix” mode and it worked. I was then able to run a SpinRite full maintenance scan (option 4 - flips every byte twice and recovers data from questionable or weak areas). It took 26 hours, but it completed without finding bad sectors. I’m going to use it as a tertiary backup drive and watch the S.M.A.R.T stats closely. I have not yet run SeaTools or other diagnostics on it.

Good luck

The drives are under warranty, but since I’m using a dock and they aren’t in a desktop, WD won’t give me support. They have been working fine the entire time I’ve had them, until now. The other one is ok, but it’s a backup and my files aren’t in the same format.

I don’t have a desktop to try it in. Like I said, it does power up and the laptop does beep when connected, but Windows can’t access it.

i don’t get the logic used by wd to refuse support when using docking stations… if you already identified the dock not being at fault, there is nothing wrong with offering a helping hand.

aaaanyway, i have not used the applications you mentioned, but for now, please post the complete smart log and try the disk with another computer.

spinrite (commercial and expensive though) is said to work wonders, but with the price tag, i wonder if its worth all those bucks (90usd).

I pasted the results of the DLG in a previous post. Unfortunately, even though I didn’t attempt to run the repair option, the drive now hangs my computer if I try to access it or use Disk Management.

I took it to a shop to try in a desktop, and it hung theirs too. They said all I could do now is try data recovery (which is way too expensive).

This drive was 3.5 months old! Needless to say, I’m not happy.

I know this post is a bit old, but I got the exact same problem mentioned here with my WD1002FEAX 1TB black. Suddenly my system became unable to boot into windows past the windows logo screen. It’s not my system drive, so I can just unplug it and then everything works fine, but still I have all my personal data in that drive so I have to find a way to access it somehow. When I try safe mode, it hangs when loading classpnp.sys. When I try to boot from the windows cd, it hangs while searching for available drives, so I can’t even use chkdisk. I tried hot-plugging it after booting into windows, but then I can only see the drive letter and icon in my computer, but it hangs even when I attempt to open the right click menu, so I can’t use any program that involves data from the faulty disk.

I’ve seen some people suggesting to switch from AHCI to IDE temporarily, but I’m not sure if that would do any good, or if that process formats the drive or not. Does anybody have knowledge about that?

I just completed a successful extraction of data from a 2 TB EARS Green drive which died rather suddenly. None of the common recovery options (Test Disk, Find and Mount Partition, etc.) did me any good. Then a fellow volunteer at a community center computer lab gave me a copy of “Hiren’s BootCD”. As the name suggests, it can boot a system, but in three different ways: mini-XP, DOS, and Linux. It is also stuffed with all sorts of Freeware utilities.

I messed with several different things in the Mini-XP boot with no helpful results. However, booting into the default Linux did the trick with a bit of experimenting. The drive did not want to mount, but when I ran a Drive Status (I think) utility which was on the desktop, it mounted. At that point I was able to use the file manager to copy what I wanted to a good drive. I do suggest disconnecting all drives except your source and destination units to avoid any mistakes.

In my case, it also made a lot of difference when I put the bad drive in an anti-static sleeve and then in a heavy quart freezer ziplock bag. When it was all sealed up I stuck it in the freezer for a couple of hours. I know this sounds crazy, but I’ve run across the advice in quite a few places. When it was good and cold, I took it out, wrapped it in a frozen gel-pack like you’d wrap around a sore knee, and then wrapped it up in towels except for the sealed end of the bag. I opened the bag enough to get SATA and power cables hooked up, and booted up from the CD.

ISO for the disk is here: http://www.hirensbootcd.org/download/

Lots of discussion here: http://www.hiren.info/pages/bootcd

I had given up on recovering anything from this disk. There were 530 GB of film scans from slides on it, representing literally hundreds of hours’ work. Give it a try!

draion changing from AHCI to IDE does not format the drive, it’s just the access mode. Note that if you installed Windows with IDE mode set, if you change to AHCI Windows will BSOD every boot. I think it works going the other way AHCI > IDE.

To the OP if you post a smart report of the drive (the smart details) we can probably tell you if the drive has failed or not. If you’re using eSATA it should be enough to get a report from WDDL and RMA if necessary.

There’s a Registry tweak to fix Windows booting if you change ACPI<>IDE. A quick search will turn it up.

I couldn’t get the WD WinDlg to work/see that HD again on my Win 7 Pro 64-bit laptop, nor the HDDScan before I took the HD to the shop to try it in a desktop… After that, I installed those utilities on an old very slow XP 32-bit machine, and WD didn’t see it, but HDDScan does. After I ran HDDScan I tried WDDL again, and then it was seen so I ran the Quick Test, which errored out and said too many bad sectors. Results for both below.

I haven’t tried them again on the Win 7 laptop, but if it’s worth an attempt to try data recovery with some free/inexpensive utility, I might as well (assuming that won’t affect an RMA).

HDDScan S.M.A.R.T. Report

Model: WDC WD10EZRX-00A8LB0
Firmware: 01.01A01
Serial: WD-[Deleted]
LBA: 1953525168

Report By: HDDScan for Windows version 3.3
Report Date: 8/12/2013 3:51:35 PM

  Num Attribute Name Value Worst Raw(hex) Threshold
001 Raw Read Error Rate 191 191 0000000000-1B94 051
003 Spin Up Time 139 134 0000000000-0FC1 021
004 Start/Stop Count 099 099 0000000000-04F8 000
005 Reallocation Sector Count 200 200 0000000000-0000 140
007 Seek Error Rate 200 200 0000000000-0000 000
009 Power-On Hours Count 099 099 0000000000-055B 000
010 Spin Retry Count 100 100 0000000000-0000 000
011 Recalibration Retries 100 100 0000000000-0000 000
012 Device Power Cycle Count 100 100 0000000000-0086 000
192 Emergency Retract Count 200 200 0000000000-0060 000
193 Load/unload Cycle Count 197 197 0000000000-2984 000
194 HDA Temperature 106 097 37 C 000
196 Reallocation Event Count 200 200 0000000000-0000 000
! 197 Current Pending Errors Count 200 200 0000000000-0005 000
198 Uncorrectable Errors Count 200 200 0000000000-0000 000
199 UltraDMA CRC Errors 200 200 0000000000-0000 000
200 Multi Zone Error Rate 200 200 0000000000-0000 000

SMART Status: Passed

Test Option: QUICK TEST
Model Number: WDC WD10EZRX-00A8LB0
Unit Serial Number: WD-[Deleted]
Firmware Number: 01.01A01
Capacity: 1000.20 GB
Test Result: FAIL
Test Error Code: 08-Too many bad sectors detected.
Test Time: 18:09:02, August 12, 2013

As far as I know, none of the utilities I mentioned do anything all that out of the ordinary. Attempting to recover data should not affect your RMA. The main factor for me, I think, was going after things under Linux instead of Windows. All the tools I used are free, too. People who run Linux full-time certainly don’t void their warranties. IMHO, you should see what you can recover, if anything.

Okay, RMA time…

If your fault description notes the drive is unresponsive in windows and you attach a WDDL report failing on too many bad sectors there shouldn’t be a problem. It used to be that any WDDL failure was grounds for an RMA, I can’t seem to find that in the support section now though.