WD10EARS slow, slow, slow, slow


#1

I purchaced 5 of these little puppies to install into a (gentoo) linux based media server - 2 with raid1, 3 with raid5

The installation was painful to say the least. Strange errors, hangs, corruptions.

So, I started from scratch again. The raid arrays would succeed (albeit painfully slowly), but the write speed was woeful.

I thought it may be the SATA channels running raid1, so I tried again without raid. Same problem.

So I took a disk out  reformatted with a single 3GB partiion and did some write tests - oh dear. It was creeping along at no more than 45 MB/s.

In desperation, I switched to a Windows XP box (yuk) - reformated with NTFS, installed the Western Digital disk utility software and tried again. Same result! Plus - lots of disk I/O errors!

Did the same tests on all 5 drives - same result.

I can only conclude that these disks are all faulty or just plain rubbish. I would advise anyone against buying these disks. I’m off to the shop to get a refund…


#2

try to follow the steps described here in this thread:

http://community.wdc.com/t5/Desktop/Problem-with-WD-Advanced-Format-drive-in-LINUX-WD15EARS/td-p/6395

hope it helps


#3

Many thanks for the info! I wish I’d seen this earlier as now the disks have been taken back to the shop and replaced for some nice Samsung F3s

As it happens, the shop (yoyotech.co.uk) confirmed that one of the disks was faulty which didn’t help metters.

I’m astonished that WD have done this - seems like a glaring oversight and I’ll be very suspicious of their products in the future.

If WD are watching this thread - where the hell are you? Do you only care about Windows users???

Thanks again nuessOr


#4

Hi,i m a system builder & deal in selling machines for video editing…Recently i bought 10 WD10EARS Hard drives as i m a system builder…at the time of installation i found it to be doing at snails pace…it took 40 minutes for an install of windows xp sp2 on following configuration…Gigabyte GA-G41MT-ES2L motherboard,intel core 2 duo 2.66-3mb cache,Kingston 1333 DDR3 Ram,Liteon DVD-RW,Cooler master 400w SMPS…al brand new…it was frustrating & irritating & i guessed something was wrong…so keeping everything else same i changed hard drive & used an old  WD 1tb with 16mb cache which i have been using,which is supposedly slower than this one…but hurrah installation was completed in flat 20 minutes…i thought there must be something wrong with this new one so opened another new one  & installed windows on it,but it was same story…40 minutes…opened another new one,but same time again…40 minutes…well,then i created partitions & copied a 40 gb folder from old HDD on one partition of new HDD…copying took 11 minute,then i copied same 40 gb folder from one partition on new HDD toanother partition  on same HDD…it took 25 minutes…This all was tried on 3 brand new HHD’s with same result…so what is wrong with much aclaimed 64 mb ecofriendly etc etc…even customer care at WD couldn’t give satisfactory solution,one of them told me to put jumper at no. 5 & 6…but no improvement…i was feeling like i m using an old P4 with 1.6 ghz cpu machine…can WD solve this problem.

Moral of the story …this WD10EARS series is USELESS  JUNK to say the least…DO NOT BUY it…


#5

More and more its looking like all EARS series drives are having issues.

Hopefully, the more people we warn about it, the sooner WD will perk up and pay attention.

I cringe at the thought of them shutting off their EADS and other factory lines and taking the Advanced Format to 100% of stock.  Truly a dark day…


#6

Some interesting facts about this EARS series hard drives

-WDC do not mention RPM for the drive in their specifications,but go to following link & click specifications.RPM is    reduced to 5400,interesting…isnt it?

http://www.newegg.com/product/product.aspx?Item=N82E16822136490

-There is no mention of RPM on the drive itself,WDC wants to keep it secret

-When i complained to customer care in india each time i got different solutions from different tech persons… some examples…one said i have to make changes in registry,i followed faithfully,made no difference…one said i have to add jumper at 5-6,other said RPM is between 5400 & 7200,it will increase as the load increases…does it mean i have to keep my drive full all the time,sounds strange…different people from same co.with different solutions…sounds very funny…

and above all you have to be very patient to get through to technicians on toll free number.

-I think it is reduction in RPM is causing all problems

-At last i returned all drives to dealer & bought Seagate.


#7

MGHolley wrote:

I cringe at the thought of them shutting off their EADS and other factory lines and taking the Advanced Format to 100% of stock.  Truly a dark day…

Look, MGHolley, the HDD manufacturers (associated in the IDEMA organization) were putting the migration to 4kb sectors for too long already (first plans were for around 2001/2002 IIRC - see IDEMA/DELL publication from 2001 and  the “IDEMA Announces a New Sector Length Standard” press release from 2006).

Moving to larger sectors allows for consolidation of error correcting data and better durability and reliability of your drives, and better safety of your data.

At the same time, there are some disk space savings and small performance gains (provided that the operating system aligns input/output requests properly to disk’s physical sectors, which is the exact problem here).

All the problems described here are simply because the OS vendors, having more than enough advance warning time since 2001, failed to adjust their products for the coming technology change  (and I’m pointing the finger both at Microsoft and at Linux community since both Windows XP and Linux’s fdisk and parted failed to prepare for this until the drives got onto the market several years later).

So I actually admire Western Digital for finally stepping up and doing this transition - they knew there will be dissatisfied customers, and that the first one to break out of this circle will get most of the flame; they knew they will be blamed for the problems which are actually caused by stagnant OS vendors. Others, like Seagate, Maxtor etc - are simply waiting for someone else to come and do the hard step.

I’m pretty confident that now - when the cat is out of the bag, and when the dust settles, OS’es and partitioning tools are updated for new sector sizes and the hardest part of 4kb sector transition is over, all these other vendors will happily introduce their own 4kb sector drives, while conveniently avoiding customer dissatisfaction which Western Digital has willfully taken upon themselves in the name of progress of the whole industry.

You just have to realize that someone had to make this step - the old format makes it extremely hard to make larger and larger hard drives and the industry got into stagnation because of that.


#8

With XP, WD10EARS really slow! I hate Advanced Format!:angry:


#9

hey guys , i am using WD10EARS with operating system windows 7 … 

i tried the jumpers in 5 6 , 7 8 , and still very slow slow slow… 

what can i do ? 

is there any solution for this ? 


#10

RMA the drive for a refund.  Check back on the product in another 6 months to a year.

WD doesn’t haver their #$^#&%^ together on this series of drives yet.

Sorry…but it seems the soundest advice for now…as WD doesn’t even have diagnostic software working for this drive yet.


#11

Only one solution…return back to dealer & get Seagate or Hitachi…WDC dont have any diagnostic for this…


#12

Just in case nobody has mentioned this in this thread, Most of the Green Caviar range is incompatible with RAID.

See here: http://community.wdc.com/t5/Other-Internal-Drives/1-TB-WD10EARS-desynch-issues-in-RAID/m-p/11559

And here: http://wdc.custhelp.com/cgi-bin/wdc.cfg/php/enduser/std_adp.php?p_faqid=1397

Though personally I think your problem has more to do with the advanced formatting in those drives… (Best resource I could find to explain was here: http://blog.fosketts.net/2009/12/23/drobo-xp-beware-4k-advanced-format-drives/ ,though the article mentions XP I have a feeling that your raid controller is doing the same thing…)

I could be wrong though.

Thoughts?


#13

Read the label

http://www.thg.ru/storage/wd_4k_sector/images/advanced-format-label.png


#14

Sorry but the issue I’m seeing here is that if the partitioning tools are told that the drive is 4k they will act appropriately.  And at least on the *nix side have been capable of doing so for quite some time.  The problem here is that the drive is reporting itself as a 512b drive - so the tools treat it as one.  That’s an emulation layer that WD wedged in there not the fault of the OS.  The OS is acting on what it’s told - the drive lies.

Sorry, I didn’t realize that actual post I was responding to was from february…

Let’s try to get WDC’s attention…It needs alot more support before they will even look at it.

http://community.wdc.com/t5/Other-Ideas/Release-non-512-byte-sector-emulated-firmware-for-WD-EARS/idi-p/21347


#15

I have just buyed Wd10ears and i want to know which operating system will run better on it Xp,Vista or 7

pls tell me

wd10ears is a slow performance hard disk but after running it for 1 hours it gets little bit of faster than startup speed it means that when it get little bit heater it starts performing well…