I have a HP P6310f machine. The interal drive that came from the factory was a WD10EADS (Green Drive)

I was using it fine until the other day. I went to turn on the machine and I get a lovely “No Bootable Device” error. I checked the Bio’s and the system clock is still correct so I ruled out the battery going bad.

I notice also the BIOS did not see any drives. Which was wierd, it didnt see the CD drive either.

So I know there is a good chance the controller on the MB is dead. I dont hear the drive spinning at all even later when I tried again and it got the Windows logo up and was trying to boot and then it froze. Drive isnt even warm.

I read on here that GREEN drives shouldnt be used as bootable system drives but it came from the manufacture with that drive.

I did run the system check that HP puts at the boot up and and came up with a HD error. I tried to go back in and do the diagnostics test to give you the error and it wont let me do it now.

I hate to lose everything on the HD (You never heard that before). Is it a matter of the HD being dead or the board on it gone? It was fine one minute and then gone the next. I thought maybe there was a new firmware that killed it since it looked like the machine tried to reboot during the night.

Any help would be great or even ways to ensure that if I replace the HD its not something else. Thank you!!!


if your drive isnt spinning, and is not getting warm - then its a good chance the board is cooked. do you have another computer to test the drive out by connecting it as a secondary, or via generic USB enclosure? I’d start there to iliminate any MB issues