WD10EADS wrong detected

Suddenly my 1TB WD10EADS is beeing wrong detected by my PC Bios.

It says “WDC ROM Model-DRAGONLY2 ATA” wit a Capacity of 63MB.

Has anyone an idea to fix this problem and my HDD gets the right firmware back?

Hi, try connecting the hard drive using another SATA cable and another SATA port on your motherboard. You can also run a test with DLG.


1 Like

The drive is identifying itself by its factory alias. This is indicative of an internal fault, probably in the firmware zone in the hidden System Area on the platters.

You could try reading the firmware modules using the utilities in the following thread:

You could also try AFF Repair Station:

An online diagnosis is free. Repair, if possible, will cost you US$50.

I tried different motherboard and SATA cables - same mistake.

I tried the test with DLG: QUICK TEST - ok! EXTENDED TEST - 08-too many bad sectors detected!

The AFF Repair Station detected my Drive not as a HDD.

I think that your guess is right.

But I think that an replacement of the HDDs firmware isn’t easy.

On the DATADONOR HP I found my WD HDD “firmware” and downloaded it.

Now my knowledge is too bad to get this firmware on the HDD.

What do I need now to do?

You can’t just download any firmware to your HDD, even if its version looks identical. There will be other differences that may render it incompatible. Moreover, there are firmware modules that are constantly changing, eg the SMART modules, defect lists, translator.

I’m not a data recovery professional, and I don’t have any firsthand experience with your problem, but I would attempt to read the drive’s existing firmware, if it is at all possible.