WD10EADS seems to have only 65133 sectors


#1

Hi,

My WD10EADS-00M2B0 seems to have only 65133 sectors (32MB) total capacity. It was OK for 9 months, and now it reports this false total number of sectors when the OS queries it. I have tested the drive with WDC’s Lifeguard Diagnostic for Windows Software. The SMART and Extended test passed, but the diag tool sees only 32MB of full drive space. Actually, the drive has 32MB cache. But during the extended sector test the heads are moving, so it looks like working. The disks are rotating. Where does the drive store the full usable sector count? Maybe this value is incorrect in the firmware? Could this value be resetted to the original 1,953,525,168 value? Or should I try to replace the PCB with a totally identical drive’s PCB? This should help if the problem is PCB related. Is there any possibility to reflash the firmware? It is strange, that all the SMART parameters are perfect.

The drive is under warranty and WD Customer Service and Support suggests to replace the whole unit, but I need my data to be restored.

Thanks, Norbert


#2

working ok for 9 months… thats strange

try in another computer and see if can acess the drive correctly


#3

I’ve tried it with 2 different PC’s with onboard SATA and with a SATA-USB conveter. All test give the same result. The drive reports 65133 total number of sectors when the OS, BIOS or other application queries it. I tried to get the disk geometry under Linux, and it also showed this information. hdparm output is:

Geometry

4/255/63 sectors=65134

I will check it after replacing the logic board with a same type HDD. If the board contains the information on the total number of sectors then it may help.


#4

Please DON’T change the logic board. A bug in Gigabyte’s Xpress Recovery BIOS has truncated your drive.

See these threads for an explanation and solution:
http://community.wdc.com/t5/Desktop/1-5-terrabyte-used-as-temporarily-backup-suddenly-shows-up-as/m-p/10747#M614
http://community.wdc.com/t5/Other-Internal-Drives/wdidle3-broke-my-wd10ears-hard-disk/m-p/40589#M404
http://community.wdc.com/t5/Desktop/WD10EARS-00Y5B1-appears-as-32Mb-max-size-after-cloning-and/m-p/25456#M1542


#5

Dear fzakbar,

thank you very much for this useful tip. You have saved all my data.

The HDD Capacity Restore was not able to detect my drive, and I could not set anything in the BIOS regarding to SATA settings. The motherboard is a Gigabyte GA K8NE and there were no “Normal” or “Compatible” or “Legacy” or “Native” modes which I could select.

The HDAT2 with boot CD worked well.

It is very interesting, why WD Support Center could not give me this tip…

So thanks again!