WD10EADS SATA drive in HP Elite Pavilion desktop not recognized in DOS


#1

I just got this computer as a HP Refurbished unit.  It has a WD10EADS 1TB SATA drive, as well as a HP SATA DVD-RAM drive.   I have tried to boot to FreeDOS to run some command line utilities and cannot access either the WD hard disk or the HP DVD by drive letters.  They are completely invisible it seems, which I find ODD because the OS booted from the DVD drive, yet no drive letter to search for files I need…

My question relates to the existence or non-existence of DOS level drivers for the SATA drives.  Where can I find DOS drivers for the WD drive?  I’ve tried switching the BIOS entry for the SATA controller back to IDE mode, but still,  neither drive is recognized by drive letter.  

Also, does WD support their own hard drives that are installed in HP machines?  Or does HP control that sector of the world too?   I tried running the Lifeguard DOS version on the WD10EADS drive and it said no drive found, error code 0120.

Thanks!   


#2

I’m not tech support, but this deals more with simple product knowledge and what WD supports.

  1. You need to make sure that HP doesn’t have an invisible partition that may be hindering what you are attempting. 
  2. You need to refer to HP or the motherboard manufacturer for SATA drivers.  Those drivers are for the ports on the MB.
  3. No we don’t.  If you bought a computer that uses our drives, you will need to go back to the OEM for support.

#3

Thanks for the info.  I wrote because I didn’t know who was responsible to support this. 

It seems neither HP, Foxconn (MB mfgr), nor WD wants to accept responsibility for resolving this issue.  I’ve searched the internet for any reference to SATA drivers for DOS and I’m not the only one having issues with DOS level drive access. 

Your response, though, begs the question…   If I had just purchased this drive myself and could not access the drive from DOS, what then would be your reply? 

Take care!