WD10EADS not detected as "physical drive" with Lifeguard

I´ve assembled a new PC a couple of days ago, at first without any troubles.
But I noticed that sometimes Win7 64bit is not booting, complaining with “Disk read error”; after several re-reboots it finally boots again.

Because of this i decided to check my internal harddisk WD10EADS with Lifeguard (chkdsk didn´t find something suspicious), BUT it´s not possible, because there is no entry for “physical drive”…?
-> I see only my Logical Drives of the HDD, 2 Partitions “C” and “D”, but the physical entry is missing.

Without that i can´t check the HDD and I am unsure what that means, any tipps?

I’m having the same issue.

with a WD1001FALS

I was using it as my only drive, with windows 7 RC, then got a intel SSD, and installed the full version of win 7, made the SSD the boot drive, using the WD caviar black as a data and programs drive.

I noticed that at random times, when I click something, I hear a short high pitched buzzing sound, and the computer not responding for several seconds. The sound I have localized to the drives.Also, today, when the computer has gone to sleep, and wakes up, the WD drive is not detected, and I have to reboot to bring it back.

I attempted to check out the drive with dlgdiag, and it only detects logical drives, and can do nothing.

I don’t have win7, but if it is anything like vista, you will need to run DLdiag as an administrator, only then it will pick up your drives as physical. Then you can do all your diagnostic testing.

wow thanks, that´s it!

I thought because my user is admin (and i am a win7 newbie) this should be sufficient - but with “Run as Administrator” i get now the list with all my physical drives. i´m going to do now the hdd tests - hopefully everything is fine…

Cool, I am glad it works for you now :smiley:

I’ve been having the same issue, except that when I right click and select run as administrator, I get the EULA and check I agree and next and the program crashes every time. Any help for that one?  I’ve installed the program several times, but the result is the same.  I have Windows 7 64 bit.

Turn off User Account Control.