WD1002FAEX only being detected by controller as SATA II?

I have the same problem on the same drive. I followed you’re instruction but when i run the file on the USB drive I get an error. Do you run the file with any switches?

Edit - Doh, I re-read and forgot to format my USB key in FAT. did that and it works perfectly. Thank you

Curious thing is, 2 weeks ago I opened an ticket with WD on this issue, they never mentioned any fix like this? Wonder why?

Again, a big thanks for posting this fix. Now running at 6GB’s :slight_smile:

I also have a similar problem with WD1002FAEX on Asus P6x58D-E motherboard. I read there is a way to perform firmware update though Windows 7 command prompt, but neither of the files above work for me. I have Windows 7 Pro x64, is there a different firmware?  Any help would be appreciated.

I have the same problem using an MSI BigBang and the Marvell controller.  I really don’t want to go through the a$$pain of reconfiguring and unpluging and replugging etc. though.  Plus, my TWO drive’re running as a RAID, so I would hate to lose one through this config process.

Do you think WD will release an ‘easier’ fix?


Same here.

Gigabyte P55A-UD4, WD1002FAEX, Seagate SataII

Executed the described process. The only change is that Everest tells WD is SataIII, but nothing else - buffer n/a, POST does not detect WD.

There is something wrong not only with WD , but with the Gigabyte’s Sata III architecture and the Marvell 9128 drivers, I think. I’m not happy at all with my new machine. Gonna give it back if the problem not solved nex week.

Does anyone have the firmware update that works with Win 7 x64? I read that there is a way to update firmware within Windows command prompt. Any feedback would greatly be appreciated. Thanks.

Can you tell us where you got the file?  I noticed the file has a “dos” at the end of it, and the readme mentions a linux version.  I was wondering if the repository you got the file from has a linux version.



I have same problems with my new two WD1002FAEX00y9ao(SATAll detact with Marvell controler).

May I have the patch please?

I have contact WD support tech who dont have mention that tool…



LorDa wrote:


Here is the file i used and provided by CEGA_Maryland (use this one as preference)


Arnaud W.


thanks mate, followed your steps and it worked perfectly.

i should however mention that i didn’t need to use sata2 ports or cables to do this operation.

just format usbstick as FAT, download unetbootin, install freedos on usbstick, drop wdsspeed.exe onto it and reboot.

set sata to ahci and usb to primary bootable device in bios, boot and run wdsspeed.exe, reboot.

undo ahci and usb boot, checked raid bios and voila, sata 6G auto-negotiated!

huge thanks to LorDa and CEGA_Maryland, WD support has a lot to learn from you guys.

hopefully the next version of wdsspd comes with x64 support.

Hey, I just got this drive, same problem, and found this forum.  Unfortunately I can’t get this to work.  When I boot up (in live mode, I think that was option 5) and type cd E: (my flash drive) it says its not working, and won’t allow access to it. This is the same for when I try and access my DVD-ROM as well (just did it to test).  I formatted the flash drive in fat before all of this as well.  Seriously WD!!! Get a x64 solution.

Anyone have any ideas as to what I can do?

ok it’s possible with x64 ( sorry i’ m french so translate with bing).

Après des heures de galère…

J’ai une carte mère asus p7p55d-e , j’ai flashé mon bios avec la nouvelle version du 10/09/2010 qui supprimait un bugg avec le pilote du marvell…

Ensuite je suis allez sous freedos à l’aide de mon cd asus en mettant mon disque dur en ahci (je n’ai pas utilisé unetboot) .

J’ai mis mon disque dur sur un port sata 2

J’ai lancer wdsspeed au moyen de la clé usb ou le fichier était copier.et j’ai rebooter

mon bios reconnait le wd1002faex en 6g sata 3.

Merci à la personne (j’ai oublié le pseudo désolé) qui à laisser le commentaire sur LDLC et le tuto sur ce site.

So this is the text that comes up when I boot from the flash drive:

UMB’s unavailable!

XCDROM V2.3, 7-24-2006

Driver name is “FDCD0000”

UltraDMA controller at I-O address FF00h, Chip I.D. 1002439Ch

No CD-ROM drive to use; XCDROM not loaded!

FreeCom version 0.84 -pre2 XMS_Swap [AUG 28 2006 00:29:00]

Cannot open CD driver FDCD0000 SHCDX33A cannot load!

There is no CD ROM, or the wrong CD-ROM!

Thats what comes up when I boot using the Fat formatted thumb drive with unetbootin on it.  Then command prompt for drive A: opens (and I don’t have a drive A). 

The My Computer window shows my thumb drive in E:, so I type cd E: and it just returns “Drive E: not responding.”

I’ve tried other drives as well.

I also booted FreeDOS from my Asus motherboard driver CD, and it boots up fine.  When I type cd E: though, it says the same thing, “Drive E: not responding.”

Any ideas?

I have tried the method with FreeDos. installed to usb drive. 

I am not sure which version to load on the GUI reboot.

I have tried all options.

My problem is that it looks for an .iso file. 

and I can’t switch directories to my flash drive where WDSSPEED is located. 

cd (change directory) command does nothing.

it gives me error.

I can only goto A:\ directory.

what am I doing wrong?

My specs.

Gigabyte x58a ud3r mobo

i7 930 cpu

Hi I have found solution in other way, I have  Asus P7P55-E PRO motherboard, in Device manager I see this http://img204.imageshack.us/img204/9972/ongelmao.png

so ill do this

1) Deleting the ACS-6XXXX from device manager (also checked the delete driver box when confirming the delete). Do not hit the scan for new devices or ACS-6XXXX will be re-installed.

2) Than I installed the USB 3.0 NEC Controller Driver for WIN 7 64.

As soon as i installed this driver windows discovered my SATA 3.0 hard drives and the USB Controller.  ACS-6XXXX no longer shows up.

USB 3.0 Solution found in: http://vip.asus.com/forum/view.aspx?id=20100201100630703&board_id=1&model=P7P55D-E+PRO&page=1&SLanguage=en-us

then I downloaded Marvell 9123/9120 Controller Driver V1.0.0.1042 from asus download page and thats all, now I am ruining my WD1002FAEX in 6Gb/s

Sorry of my English 

yup, i have the same problem … so  anyone could solve the problem? if  someone has the file that run within window  7 x64 please send me !! Enmanuel_c@hotmail.com !!

ok it’s possible with x64, après des heures de galère…

J’ai une carte mère asus p7p55d-e , j’ai flashé mon bios avec la nouvelle version du 10/09/2010 qui supprimait un bugg avec le pilote du marvell…

Ensuite je suis allez sous freedos à l’aide de mon cd asus en mettant mon disque dur en ahci (je n’ai pas utilisé unetboot) .

J’ai mis mon disque dur sur un port sata 2

J’ai lancer wdsspeed au moyen de la clé usb ou le fichier était copier.et j’ai rebooter

mon bios reconnait le wd1002faex en 6g sata 3.

Merci à la personne (j’ai oublié le pseudo désolé) qui à laisser le commentaire sur LDLC et le tuto sur ce site.

Ca ne marche pas ?

Moi j’ai une carte mère ASUS P6X58D-E, un Core i7 960, 8 Go de ram PC 16000, une GTX 480… et deux WD Caviar Black 1 To - 64 Mo - 7200 tr/mn - SATA III (un pour le système, un pour les données) et je suis sous Seven Pro 64 bits

[translated by google]

ok it’s possible With x64, after hours of galley …

I have a asus motherboard P7P55D-e, I flashed my bios with the new version of 10/09/2010 which removed a bugg with the marvell driver …
Then I go under freedos using my asus cd through my hard drive in AHCI (I have not used unetboot).
I put my hard drive to a SATA 2 port
I start wdsspeed using the usb or the file was copier.et I reboot
My bios recognizes the SATA wd1002faex in 6g 3.
Thank you to the person (sorry I forgot the nickname) who leave the comment on LDLC and the tutorial on this site.
It does not work?

Si si ca marche véridique.

Ne pas utiliser UNETBOOT

-mettre le dd sur un port  sata 2 .sous BIOS dd en AHCI

-Flasher le bios avec la nouvelle version de marvell.( moi c la 10.2 )

-lancer freedos depuis le cd ASUS fourni avec la carte mère.

-une fois sous c :confused: rechercher la clé usb de mémoire pour moi c’était B: ( pas sûre du tout ) ,clé usb sans unetboot.

-lancer le firmware de mémoire je l’ai lancé deux fois .

-un message s 'affiche pour rebooter.

-une fois le boot réaliser arrèter windows remettre le dd en sata 3 et le 1002faex est reconnu en sata 3 6go

config: -Asus P7P55D-E .

             -proc i5 760

             - dd black caviar 1to SATA III 64mo cache

             - SSD C300 64go SATA III

             - HD 5770 1go DDR5 .

G pas reussi la manip du jour au lendemain g du mettre une semaine pour tt mettre en  place mais véridique ca marche.

Bon courage g réaliser cette manip mi - septembre désolé pour le manque de précision mais dans l’action g pas tt noté

[Translated Google]

If it works, if true.  Do not use UNETBOOT  Put the dd-on sata port 2. AHCI in BIOS dd
-Flashing the bios with the new version of Marvell. (Me c the 10.2)
Freedos-launch from the ASUS CD that came with the motherboard.
Once-in c: / search the USB memory key for me was B (not sure at all), usb stick without unetboot.
-Start the firmware memory I called twice.
-Message 's poster for reboot.
Once the boot-stop Windows realize the return dd sata 3 and sata 1002faex is recognized 6GB 3
config-Asus P7P55D-E.
             Proc-i5 760
             - Dd black caviar 1tb 64mb cache SATA III
             - 64GB SATA SSD C300 III
             - HD 5770 1GB DDR5.
G not succeeded the manip overnight g post a week to implement but tt true it works.
Good luck achieving this manip mid g - September sorry for the lack of precision in the action but not g rated tt

I also FAEX 00Y9A0



I am having a similar problem except my drive is being detected as SATA 1.5 when in RAID mode, I have yet to check to see if this is true in AHCI mode.

To “solve” this problem, I’ve placed a jumper over pins 5-6 to supposedly limit the speed to SATA 3.0, but what if my RAID controller is giving me false reports? That’s what I am afraid of.

I’ll be running some benchmarks to make sure I am running in SATA II mode tonight. I’ll probably have to check what batch I received as well.

Motherboard:  ASUS M4A78T-E

I just want to thank you guys so much for this. I had opened a case with WDC support earlier, but never got around to having them call me.  I was looking around in Hard Disk Sentinel that I was on Sata-II controller, and not using Gen 3 signalling.  This has been troubling me for sometime, thankfully I ran across this forum post :smiley:

I noticed that the steps LorDa took are a bit different then what I had to do so, below are the steps that I had to take to get this working.

Note: I’m using windows 7 64bit, and my drives are already in AHCI mode.

  1. Format USB key to FAT

  2. Download unetbootin and installed FreeDOS to my USB key

  3. Downloaded the wdsspd files from LorDa’s links ( I used the version)

  4. Copied the files to the usb drive, I put the files in a folder on the usb called wdsspd2

  5. rebooted my computer went into bios and set my USB-HDD (usb key) to be first in boot order, and set to boot from USB-HDD before Hard Disk.

  6. saved changes to bios rebooted and when freeDOS window came up pressed enter on the “default” option

  7. Selected the start FreeDOS in safe mode option

  8. At the A:> prompt entered cdd c:

  9. At the c:> prompt entered cd wdsspd2

  10. Now at the c:\wdsspd2> prompt did wdsspd -R (so I could see what my drives were currently set to, they were set to use 3.0 and 1.5 but avoid 6.0)

11.At the c:\wdsspd2> prompt did  wdsspd -A to set the drives to always search for highest available

  1. rebooted with usb drive not in computer went into hard drive sentinel and presto everything is all good :slight_smile:

Note you can read the txt file or do wdsspd -? at the prompts to see all the options for the wdsspd program.

Also, in the instructions it says this is for windows 32 or 64 bit and to run from an elevated dos console(command prompt) in windows, that method did NOT work, I had to do this in FreeDOS.

Hope this helps some others.