WD1002FAEX drive suffixes

I’m wondering what the letters after FAEX in the drive model number mean. 

Specifically, I have two drives:

one is WD1002FAEX-00z3a0, manufacturered dec 2010 in Thailand, and purchased new.

the other is WD1002FAEX-00y9a0, recertified, manufactured 14 Nov 2011 in Thailand (I thought the factories were shut down?), that I received on a RMA advance replacement for the first drive. 

I no longer think that the original drive was defective.  The replacement drive has allowed me to troubleshoot and identify that the problem was on the filesystem.  My question is which drive should I keep, and which should I send back to WD?  Also, how was the second drive made in Thailand during Nov 2011?

The history behind the RMA is as follows:

I was in the midst of a system upgrade.  I was replacing my SSD with a bigger and faster one, replacing my 2TB caviar green advanced format drive with the caviar black, and moving and resizing partitions all over the place using clonezilla.  In particular, I moved my windows 7 boot partiton (the regular-size one, not the 100mb one) from the old SSD (formatted MBR) to the caviar green drive (formatted GPT).  I then later moved that same partition to the caviar black drive, which is when I started noticing problems. 

My caviar black drive was causing my motherboard to fail to post.  When the drive was connected to one of the sata ports on the chipset, and those ports were in AHCI mode, the bios would hang indefinately during drive detection when it got to whatever port the caviar black drive was on.  If I hotplugged the drive, it worked fine, and if I plugged it into a separate sata controller, it worked fine. If I was running in IDE mode, it worked fine.

Also, after hotplugging the drive, running hdparm -I (capital i) in linux generated an I/O error.

I got confused when the replacement drive started exhibiting the same problems, since the chance of receiving a replacement drive with the exact same problem is basically zero.  I should note that I have several other hard drives and SSDs in my machine, none of which were causing this problem, just the two caviar black drives.  The only thing I could think of is that it was a problem with the filesystem, which I had cloned onto the new drive.  Sure enough, when I deleted the partition table, the problem went away (my data was all backed up). 

The clonezilla documentation mentions that it doesn’t fully support cloning a partition from a 512b drive onto a WD advanced format 4k drive, which I did (before I read the documentation), and then I subsequently copied that partition to the Caviar black drive.  My hunch is that the problem is either this, or the fact that there were two identical partitions with the same “unique” id connected to the system at the same time, on different physical drives.

Anybody have any ideas what might have caused this?

Try using the OPT1 jumper to reduce the SATA interface speed. That may circumvent any problems in the autonegotiation process.

Jumper Settings for WD SATA and EIDE Hard Drives:

As for the model number suffix, see http://community.wdc.com/t5/Desktop/Product-number-help/m-p/274980#M7201