WD1001FALS, Windows 7 - 64, Shows in Device Manager but not My Computer


#1

All right I put in the above listed hard drive and it shows in the device manager.  When I try to format it or assign it a drive letter in Disk Management I get an error that say:

Error Window

Furthermore, my roommate also has a Windows 7 x64 system and when we put it in his computer it works fine without having to format.  It automatically ran through a little update process and worked on startup.

I appreciate the help in advance.


#2

I put a couple different variants of the motherboad drivers on and uninstalled the hard drive a few times.  Eventually it all came together.

Problem solved.


#3

I’m having the same problem with my 1TB caviar black.  i haven’t updated the motherboard yet but your saying that is what fixed it?   I have an Asus Rampage Extreme II but i have to assume it’ll sync up upon an update.  The Rampage Ext II comes Vista 64bit ready but not Windows 7 ready.

why did you have to install several updates??  was there a particular fix update?

thanks for any heads up here before i start “updating” willy nilly.


#4

Oh and did you uninstall the drive through the device manager?  i see mine there too just not in My computer as you said.  So yours appeared on start up eventually?

thanks.


#5

Did you have to d.l a driver from WD manually or can you fix this with a Windows update? (automatic).


#6

I put the most recent drivers on directly from nVidia.  That didn’t work so I put the most recent ones on directly from the motherboard manufacturer (XFX in my case).

I then uninstalled directly from the device manager and restarted my PC.  When it started back up it ran a little autoinstall and prompted me to format.  I accepted the format and it worked like a charm in a couple seconds.