WD1001FALS Bad Sector Problem


#1

Alright so I’ve had this 1tb hard drive for a few months now, I got curious as to how well it was performing, so I started up HD Tune, only to notice a few issues. I had warning signs in Smart for C7 and C5. Well warning signs are never good, so I started poking around and decided to download Western Digital’s Lifeguard App and scan the drives for errors. Immediately I noticed I was unable to perform the quick scan, it would give me the following error

Code:

06-Quick Test on drive 1 did not complete! Status code = 07 (Failed read test element), Failure Checkpoint = 97 (Unknown Test) SMART self-test did not complete on drive 1!

It recommended I try the extended drive test, so I gave that a shot, as soon as it finished it found problems and wanted me to repair them, I tried to do so only to have it spit out another error.

Code:

08-Error was detected while repairing bad sectors.

So being the paranoid I am, I started to immediately back up everything and could even swore I heard the drive clicking. Anyways I remembered that sometimes windows is not capable of repairing drives while it’s active, burned a boot disc and ran the WD Lifeguard utility from a CD. Ran the extended test again, it found the errors again, but this time it managed to repair them. I ran the quick test both from the Boot CD and later from within Windows and the drive passed the test.

Now my worry is that, this drive although passing the tests might actually end up failing sooner than I would like, I’m not too familiar with the SMART readings so I’ve included them as well. I was wondering what other people think about my situation. The new HD Tune readings are below, the C5 error i was getting before about Current Pending Sector changes no longer appears, yet Under Reallocated Sector Count, The status remains 0, I’m wondering how the drive had found sector errors yet fixed with them without relocating them?

Another issue is the C7 DMA CRC Error Count, I’m still getting a warning for that, my slick googling skills revealed that that error is primarily caused by a bad cable… well I’ve tried a few cables and the warning doesn’t go away. Currently I’m keeping a watch on it and making sure it doesn’t change.

Any advice or reassurance would be lovely.

ID Current Worst Threshold Data Status
(01) Raw Read Error Rate 200 188 51 151 ok
(03) Spin Up Time 253 215 21 3583 ok
(04) Start/Stop Count 100 100 0 425 ok
(05) Reallocated Sector Count 200 200 140 0 ok
(07) Seek Error Rate 100 253 0 0 ok
(09) Power On Hours Count 97 97 0 2426 ok
(0A) Spin Retry Count 100 100 0 0 ok
(0B) Calibration Retry Count 100 100 0 0 ok
(0C) Power Cycle Count 100 100 0 415 ok
(C0) Power Off Retract Count 200 200 0 145 ok
(C1) Load Cycle Count 200 200 0 425 ok
(C2) Temperature 115 90 0 35 ok
(C4) Reallocated Event Count 200 200 0 0 ok
(C5) Current Pending Sector 200 200 0 0 ok
(C6) Offline Uncorrectable 100 253 0 0 ok
(C7) Ultra DMA CRC Error Count 200 200 0 21341 warning
(C8) Write Error Rate 100 253 0 0 ok

Health Status : warning


#2

Check cables and power.  Otherwise, a smart error is bad news for the drive.


#3

I have the exact same issue, black 1TB that fails quick test with status code = 007, failure checkpoint 97 (Unknown Test) It’s as though this drive is not compatible with WinDlg and I have tried MANY versions! I am running XP, how is it possible some of my drives (WD20EADS) pass and this one has that error? I put this drive on the shelf for now, I have 20+ drives of 1, 1.5 & 2TB and am pretty frustrated that the “top” series from WD is my most problematic! Here is my thread that went nowhere as far as getting any help. It will be worth your time to have a look. http://community.wdc.com/t5/Desktop/Problems-Questions-16-WD-drives-WD1001FALS-00J7B1-amp-WD20EADS/m-p/14112#M830