WD_xxxx_JS power-up in standby feature


#1

Hello,

I have enabled by software the “power-up in stanby feature”. No I cannot disable it anymore. Yes, the drive has a jumper for this feature, but after the feature is changed in software the jumper is useless.

I’ve tried almost everything:

  • HDAPRM as provided in the latest Ubuntu dist. HDPARM can enable this feature but it cannot disable it.

  • HDAT2 latest version. HDAT2 can enable this feature and wake up the drive if it is not properly detected by the BIOS but it cannot disable it also.
    If you you want to use this drive in a normal desktop(without BIOS support for this feature) the drive is pretty much useless as you will need to wake it up after every time the system is powered off.

After a google search I have found out that this issue is very old and that almost all the drives in this series(and maybe others) are affected. Is there any way to fix this? I’ve searched the wdc website for the proper firmware for this drive hopping that a firmware re-write will reset the drive’s settings but with no success(there isn’t any firmware for this particular model).

I have even tried other manufacturers tools, but there is no option for this feature.

Other than that, this the drive is in perfect condition: no errors found using dldiag’s extended test. It is really a shame that a small bug like this can make a perfectly healthy disk almost useless to a normal user.

I have posted here hoping that someone found / will find a solution for this issue.

* Drive: WD1600JS-22NCB1

* Correction: The drive is “js”, not “ys”, I’ve mistyped.

Thank you for your time!

LATER EDIT: So i guess that there is no way to fix this or that no one experienced similar issues? I visited this thread almost every day and still no responses/feedback. :frowning:


#2

Yeah I have 10 of the WD2500JS-57MHB1 with the same problem. I suspect they are working properly, although I haven’t gotten them to power on and test them. I don’t want to disable the PUIS and have them be stuck with it enabled. So I too have been searching for answers without much luck. I know these drives are older and not a top priority, but if enough people complain maybe we can get a firware fix. 

I agree with 'Flow1264   ',  “It is really a shame that a small bug like this can make a perfectly healthy disk almost useless to a normal user.”


#3

I have EXCACTLY the same problem with 3 WD10EACS, im actually glad for your post becuase now i atleast KNOW what i did wrong.

I was trying to find out why my disks were not spinning down on linux and ended with 3 drives that can only be spun up by linux, worst part is, now i actually want to move them to a windows pc but am unable to.

It’s a simple SMART feature, i can’t believe there is no fix to this, a simple tool by WD to reset the drives settings would do!

Maybe that’s to much to ask for…


#4

Update to my earlier post. It is possible to disable the PUIS with the WD2500JS-57MHB1 and it does not get stuck with it being enabled, as I have read about other similar drives having a firmware bug that does such. Using the ‘ultimate boot cd’ and hdat2, upon loading the program it detected and disabled PUIS automatically. After reboot the hard drive powered up as normal and did so after several reboots. So I was happy to finally have working hard drives, their performance is another story. These drives do not work well in a raid. Tried them on an ich9r in many configurations and barely got over a single drives write performance, and sometimes lower. I think since these drives were pulled from dvr’s their firmware is not optimized for random r/w performance. So now I’m going to sell them. Hope the update helps.


#5

Are you saying that HDAT2 could disable the setting where HDPARM failed or what was your problem.

I dunno how you got into the situation of having this feature enabled but sounds like you just have one of the drivers where the feature is NOT bugged!

PS. I contacted WDC, they don’t give a **bleep** so i’m going to start using Samsung Green disks and telling everyone i know why they should do the same.

Worst part is, they just gave me some lame feedback about not supporting Linux which has nothing to do with the issue and i explained that thoroughly in the mail.