WD will not IP after installing new Netgear WNDR3700 router


#1

Hopefully someone can help out.  I’ve been running both a WD TV Live and a WD TV Live Plus (don’t the names **bleep**) since their respective product launches with ZERO issues.  A couple of weeks after switching from a Cisco WRT310N router to a Netgear WNDR3700 router, my WD’s lost their IP (I believe some time after the 1.04.17 f/w upgrade), and now the WD’s are unable to obtain an IP from the DHCP server (the netgear router), and if I enter the IP into the WD manually, the unit will not pass the DNS check in the Check Connectivity routine.

I have tried downgrading the WD firmware to v1.04.10, no difference.

Here’s some of the network details.

My router’s DHCP/Gateway IP : 192.168.1.1

Subnet Mask:  255.255.255.0

In the manual IP set up of the WD I’ve set the following:

IP Address: 192.168.1.9 

Subnet Mask: 255.255.255.0

Gateway: 192.168.1.1

DNS:  192.168.1.1

( I have also tried my ISP’s primary and secondary DNS, but no luck)

If I allow the WD to try to automagicly get’s it’s IP,  in loads it’s defaults

IP Address 169.254.169.238

Subnet Mask: 255.255.0.0

Gateway: 0.0.0.0

DNS: 0.0.0.0

I’ve also let it cool for days (the overheating network chip / cracked solder joint issue) with no results. 

Did I miss anything?


#2

Same issue here…

Went from a Netgear WGT634U to the WNDR3700.

Configured the WD to access the new network using the automatic option.  The device connects to the router and gets an IP address fine.  From the router, I can see the MAC address of the WD.  It shows the same IP address as what the WD is claiming.

On the Check Connection dialog, it passes on the IP address check and never completes the DNS check.

What’s going on with the WNDR3700?


#3

I have been using the WNDR3700 since August and it has been working great! My WNDR3700 has firmware 1.0.4.68. I have been reading a lot of information on the Netgear WNDR3700 forum, and a lot of people are having issues with newer firmware. Version 1.0.4.68 has some issues as well, including a memory leak problem, but the newer firmware had many more problems. Netgear released firmware version 1.0.6.98, but it had so many problems that it was pulled.

The 2 points that I am trying to make…

If you have the newer Netgear firmware you might want to downgrade to 1.0.4.68.

The problem might be the WNDR3700 and not the WD box.

Here is the link to the Netgear forum if you are interested.

WNDR3700 Forum

EDIT: Some people have used the address reservation feature of the 3700 to get around the DHCP problems. Go into the 3700’s web setup, select Advanced, then LAN setup, then manually enter an IP address for the WD box. If you do it that way you can leave the WD box set to get the IP automatically from the DHCP server.


#4

Had the problem with my WNR3500.

Set Address Reservation using the MAC of my WDTV Live and the static IP I set on the WDTV Live and presto…problem gone…:slight_smile:


#5

No Joy for me…

I reserved an IP address on the router and let the WDTV auto-configure to the router.  The WDTV seems to get the reserved IP address but when the Check Connection dialog is run, the DHCP test fails.

Any other ideas???

running 1.0.4.68NA firmware and the router thinks that this is the latest version.


#6

I have seen problems with the Netgear DHCP implementation.

Try setting a static IP on the WDTV Live AND setting the same address reserved on the router.


#7

I’m returning my WDTV Live. It worked fine on my WNDR3700 for a few days but after getting stuck on a particular MKV it now won’t play anything including AVIs. It freezes after a while and looses network connection. Only unplugging for a few minutes will restore the connection. Try this!

Anyhow the wierd thing is on the router status page it still shows connection at 10Mb/FULL. So I’m assuming it must be the WDTV Live. Starting to think the new one will end up doing the same. Went up and down firmwares and still no fix. So maybe it has suffered from overheating and is now buggered.

But it did work for a while!


#8

Here’s an interesting thing…

I plugged the WDTV directly into the router, configured the WDTV to the network using the Automatic configuration function and …  VOILA!!  I can access my network shares and my media server!

When I run the network connection test, it passes all three tests.

Why would the DHCP test pass with a direct connection and fail via WIFI?


#9

“Why would the DHCP test pass with a direct connection and fail via WIFI?”

Incompatible wifi dongle?


#10

NO.   If the WiFi setup menu appears, then the dongle is compatible.

Check to make sure you don’t have WiFI Isolation configured on the router.


#11

I have the same issue with my Netgear and WD TV live.  I’m so frustrated with this thing I think I’m just going to return it.


#12

Yesterday, Netgear released a new firmware update for the wndr3700. Version 1.0.7.98 fixed many problems. One of the fixes is:  “Some IA appliances can’t get IP address issues”. Perhaps you should try to update the 3700 and see if that helps.

Netgear v1.0.7.98