WD Utilities and WD Security Crashing on Macbook Pro

Hi, I have two WD My Passport Studio Firewire drives, 1TB and 2TB.
The drives do work perfect, but the new WD software does not work, both, WD Utilities AND WD Security crashes immediately after opening.
I can still use the old WD utilities, version 1.1.3.1 with no problems at all.
I tried last year to update WD Utilities, after the update I got messages that the Firewire on both drives had problems. After reinstall the old version everything was OK again.
Today I downloaded the latest version of WD Security to change my passwords and the new WD Utilities with no luck, as I said, both do crash immediately after opening.
Do not understand why, my Mac is fine, MacOS El Capitan 10.11.6, no problems at all…
Anyone? Thanks a lot!

Since apps have been re-installed from scratch several times and old revisions do work then perhaps there is another system-wide application or setting in conflict with the current apps. I’d recommend sending an E-mail to WD Support about this. You can do so in the following link:

Try to provide as many details as possible related to the issue in question and what you have tried so far. They will contact you if they need additional information.