WD update server is constantly unavailable

With the WD SmartWare I cannot access the “Backup” or “Retrieve” tabs. I have uninstalled and reinstalled the software a number of times with no success. Has anyone solved this issue?

Hi, do you have a compatible WD Drive connected to the computer?

I have the WD My Cloud connected to the router. It is not connected to the computer as instructions say not to connect it to computer via USB. The blue light is consistently on at the front suggesting the device is connected properly. Still no access to “Backup” or “Retrieve” tabs in and “Update Software” consistently says “WD update server is currently unavailable”

The WD SmartWare software is version - I have no idea if this version needs updated or not as I consistently get the message “WD update server is currently unavailable”.

Your smartware version is too old and is not designed to work with the My Cloud, honestly I don’t think it will recognize any of WD’s network drives, uninstall it and get the latest version from the link below.


Thanks for this but I am on a Mac and hence could not use the link provided as it is for Windows. Still having no success with the backup!