WD Unlocker not responding to startup command

I downloaded the latest version of the Unlocker.exe and put a shortcut to it in my startup folder. It does not launch on startup; instead I get a message that the file “WD” will not open. Using Windows 10. I tried changing the name of the program but was not allowed.
I put a shortcut on my desktop, and that usually works; it is the automatic startup I am looking for. I added a five-minute delay, but still no go.
I have a Passport Ultra.


Have you tried uninstalling and reinstalling the software?

Thanks for your suggestion. If you mean the unlocker program, I had (as mentioned) just downloaded the latest version and installed it. In the folder where startup programs are listed, the full name of the unlocker is shown, but for some reason the startup feature is only grabbing the letters “WD”, which does not work. There was a time when it worked properly, but for some time now I have had this problem, which is why I reinstalled, but the problem persists. I am still able to unlock manually using the desktop shortcut.