WD unlocker application fails to launch on WIndows XP- limited account

The hard drive is password protected and needs to stay that way. I can log in and access the drive though admin and “run as admin” but I cannot give out the password to other limited users that need the drive. As soon as I plug in the external I get:  “The app has encountered an unexpected error and is now exiting”. Already tried some simple things like upgrading smartware and firmware, uninstall and reinstall of the smartware program and SES driver.

on a side note when i tried to upgrade the firm ware a small yellow triangle popped up and said that something could not be saved to the hard drive(didnt say which one but i guess its the external) and half path of where it was trying to save. yet the firmware upgrader says it completed the upgrade succesfully (tried this many times and same results.)

as a precaution i also did this again on a PC running Windows 7 and got no errors.

the hard drive is a WD MyPassport WDBAAA3200ABK

Does the drive comes with the VCD Smartware or does it have the unlocker?

If it has the Smartware VCD you can open the VCD and run the application