WD Twonky setup changes via SSH root having no effect

I will do that, thanks. Which directory is the log file created in?

/var/log There are several log files.
try using tail -50 This will display the last 50 lines of the file. The log files are on disk as filename.log filename.log.1 and filename.log.2.gz with the .2.gz file being the oldest.


It’s no use, I can’t SSH via putty: ‘Network error: connection refused’. I’ve rebooted my router, done another full reset having unplugged the ethernet cable. But it still sits there with a white LED and ‘Device Initializing’ in the GUI. The Twonky GUI comes up as normal and shows all my music. Still can’t SSH after another reboot, and I’m using the same IP address as the GUI links and in the network map. I’ve been able to copy some files I had on there to my laptop for safety (my music is already backed up). But it just won’t settle down and share. Arghhhhhhhhhhh

There is a program called psftp located where you got putty. This will alow you to sftp into the My Cloud. From there you could cd to the /var/log directory and do a get on the different log files.
If the sftp works hen you can look at the logs on you PC.



So I copied and pasted your script above using notepad in Win10 then transfered it to “My Cloud” using filezilla, placed it /CacheVolume/user-start then using putty did to change the permissions chmod 777 user-start.

I’ve since done a reboot and the file didn’t run, so what has this noob done wrong ?

I’ve never tried to run a script at boot in Linux


What firmware are you running?

How do you know it didn’t work?

Had you copied your original files to the /DataVolume locations?

Well I’m guessing here but…

I have my music in various folders 0-99, A-F etc and shared in Twonky. I recently updated the firmware, and my twonky settings have now reverted back to \public

Which make me think it didn’t work.

V4 or V2?

And the third question?

You could add a logging command to the script; say send the date to a logfile in /DataVolume.

date >> /DataVolume/shares/Public/Software/MyCloud/user-start.log

Sorry V4 and yes I copied the file.

Okay I worked out why the script wouldn’t run. It was in DOS format. That’s what you get for working with novices…

I runs now, but doesn’t stick ? It changes the shares to what I want, but then for some reason it reverts back to /public within a few seconds ??

Have a look at the content of the contentdir and twonkyserver.ini files to see what they’re instructing the search path to be. It may well be that the twonkyserver.ini file is correct, but the contentdir is still directing to Public.

Check the Twonky FAQ thread for details of the two files.

cheers, contentdir was wrong :grin:

1 Like