WD TV Remote app problems

The latest update has broken something on the iOS app. I only can select one of my WD TV SMP devices where prior to the update I could choose between the two. Additionally this feature works properly on my android device. Please fix.

Hello, try uninstalling the app and then do a clean install of the latest version. 

I tried that twice but no luck. This occurs on an iPad 2 and an iPhone 4. Additionally I can’t seem to do a “clean” install of the latest version. When I select to install the app from iTunes I get the old version and then can update. Any other suggestions to try.

I also just tried turning off the device that was being seen by the iOS version going the other device would show up but that didn’t work. Any thoughts on why the device would work on the Android version and not the other?

Working device configuration:
ip address = .19
Name = WDTVupstairs

Non working device:
Ip address = .20
Name = WDTVlive

Both are wired on the same network.

So it appears the new remote is not compatible with the older firmware. So the solution was to update to the latest firmware.