WD TV Media Player Firmware Version 1.02.17 (12/16/14)

I’ve played the test video Sita sings… and it not exhibit the issue!

I’ll try it again, but I’m amazed as this is the first time it’s worked since I brought it 8 months ago,

and WD tech support never suggested doing this, after many hours on the phone to them.

I should be able to narrow down the problem now and I’ll report back with results.

well, that’s good to hear … so it’s your files then ?

no that’s unlikely - I’m suspecting a rouge DLNA server as KAD79 suggests? (I have a few on my network)

Just connected the LAN cable & will play the same video again to see if I can get it to fail.

ok, no probs … at least we may be getting somewhere with nailing down the cause

If you are using Network shares, and the media library I’m not sure how DNA would be an issue. It is not being used.

bok007 wrote:

My issue is that I have to reset the WDC back to factory defaults, to get it going again,

Every time I want to watch a video.

This problem is easily repeatable on any video more than 30min long.

It happens on network shares or locally attached storage.

It happens on ALL types of videos (.mp4, mkv, avi…)

It happens on different WDC players as well!

I don’t know if I can be bothered logging another case, and waiting another 8 months or longer?

Why is it that every time a new firmware is out there’s at least two threads about it cause people keep opening new ones instead of continuing in the one already started? That said, your problem looks like it could be a variation of  bug #4 we’re still trying to get to the bottom of.

JoeySmyth wrote:

oh, ok  :neutral_face:    my wdtv is connected Wired to my route

 

if it is a dlna bug … how do you fix that ? 

 

my Billion Modem/Router has UPnP settings Enable / Disable  (currently it’s Enabled)  would disabling UPnP disable DLNA ? and still you use Network Shares?

I’d have to read up on the UPnP setting in the router, that very well might disable it

but the idea there regarding DNLA is this

WD is happily playing a movie off the locally attached hdd

DLNA server is misbehaving and tries to take over causing the WD to crash

I haven’t tried it in a long long time

but back when I updated all the WDLXTV upnp tools, I could definetely reliably crash the WD in this method

@Joey, I’ll send you some info via PM on how I used to be able to crash the device, cmd line stuff again, in case your interested

so if having the WD completely disconnected from the network resolves the issue

then the next step may be as joey suggested to try and disable all dnla servers on the network

either by blocking dnla / upnp at router level or by finding and disabling all dnla servers

the most common poorly implemented misbehaving dnla servers I’ve found are usually running on a phone or tablet

but certainly servers running on a PC, NAS, router, etc … can’t be ruled out yet

I have a few DLNA servers on the network;

Windows Media Player
Windows Media Centre
Plex
TVersity

But at this stage it looks like the Seagate Blackarmor DLNA server was the root cause.

Even if you played files from a locally  attached HDD!

testing continues…

I have a DLNA server on one of my networks and I don’t see this bug ever.

Techflaws wrote:

I have a DLNA server on one of my networks and I don’t see this bug ever.

not every dnla sever is problematic

I’ve got a dnla server on my network as well with no issues

So far today, I found eveything seems to work from a local HDD.

Network shares still exhibit the issue however.

I’m trying NFS rather than windows shares now.

WD TV shows no DLNA servers on the network, but I get the issue.

so even if dnla is not the issue at least you’ve narrowed it down to something network related

the WD has a 10/100 port

you might want to make sure jumbo frames are turned off, and you could also try manually setting the port speed on your routers end to 100 instead of leaving it on auto

Hi Bok007,

I had similar issues and after swapping wdtv’s via rma still had same problem.

Are you running a Microsoft Windows Domain network ?? If you are then that is the problem.

I split my LAN into 2 segments one for windows domain 192.168.3.x and a seperate non windows segment for WDTV’s and QNAP NAS 192.168.2.x

All problems solved.

not sure if this helps but worth checking as WD would not tell me about Domain compatibility of their devices.

Glyn

Thanks for the suggestiions, I’m slowly going through all the possibilities.

Linux shares (NFS) also show the issue.

I have an old WD TV Live Plus that exhibits the issue too.

Last night I reset the WD TV after watching a movie,

then when I tried to play something this morning it wouldn’t work.

Obviously something on the network is not right,

sending bad packets to the WD causing it to crash.

Maybe I could try a packet capture using Wireshark?

here’s something again about dlna upnp

http://wiki.wdlxtv.com/Superhub

this was such a problem actually made it into the wdlxtv wiki

regarding upnp advertisement packets, which while similiar is actually different from the original dlna bug I was thinking of

1 Like

Thanks KAD for the info

Are there any logs on the WD TV to help diagnose this issue?

on official firmware you don’t have access to any logs

if you think it’s the black armor

maybe turn the black armor off, powered down

then reboot everything else see if that fixes it

that would at least narrow it down to a specific device

Just tried playing an MP4 from a windows share on my laptop, still got the problem.

so it must be one of these things broadcasting something?

WDTV

WDTV Live Plus

Seagate Blackarmor

2x Windows 7 laptops

1x Windows 8.1 laptop

ipad

iphone

samsung tablet

samsung phone

technicolor modem TG 582n (used as switch & AP)

technicolor modem TG 589vn V2 (used as VDSL, switch & AP)

DLINK DSL-G604T (used as a switch)