WD TV Live will not play any files


#1

I wonder if anyone has had this issue. i’ve had my player with 2TB external WD drive for months now and i have had no issues with it. but since last thursday whenever i try to play any type of video file it just thinks about it and never starts the movie. i tried connecting another USB and it does the same thing. I have tried RESETTING it using the menu ‘Reset to Factory’ and also the small button at the back but the problem still happens. Any help will be appreciated.


#2

After you reset did you try unplugging it for at least 10 minutes (longer is better) and then plugging it back into power again?


#3

Thanks for this - have not tried yet but will give it a go when i get back home tonight. What if i do as you suggest and it doesnt work, what will plan B be?


#4

That comes after plan A has failed. (I really wanted to be Hannibal from the A Team and say ‘There is no plan B’ and that might just be true).


#5

Rich,

LOL – that’s *exactly* what I had started to type and then thought better of it (didn’t want to be a smart-bottom which is why I didn’t reply to him). 

Okay, so great minds think alike, right?


#6

ok guys i did as you suggested and still no luck. the **bleep** thing gets stuck on the loading page with the wheel spinning. any other thoughts?


#7

As Cameron Swazye used to say, “It’s time for a new Timex”.

Assuming you’ve tried formatting your drives, using a small flash USB drive or anything else without success, contact WD for replacement or repair.


#8

I am presuming that the thing works OK WITHOUT a USB device attached.

If the USB light is flashing, then the WDTV is still trying to create the Media Library.   You could try turning that function OFF and see if that helps.


#9

Ok I found out what the problem was. Basically one of the files that I was trying to put on my external drive was ripped using a new version of mkvmerge, and for some reason the wd tv device didn’t like that and it stopped all the other files from playing, thus is how i managed to fix it : I downgraded and ripped the mkv file using mkvmerge 2.4.1 from http://jonthn.free.fr/MKVtoolnix/ and then it played on my wd tv without any issues. Hope this help those who have the same problem as me. Thanks to all those who contributed to this post.


#10

You can actually use either any version of MKVMerge 4.0 or earlier, OR use any later version by going to the audio and video tracks and turning off header compression.

However – that one file should not stop the Live from playing other files that played before.  That doesn’t make any sense at all.


#11

So the “new” MKV file caused all files to not work at all? We have this same problem right now - we attempted to play a new MKV file and now nothing else (including AVIs) will play, even after a reset. But how can it impact other files that we just watched this weekend?


#12

I guess it’s plausible that the Header Compression (or anything “wrong”, for that matter) leaves the WDTV in a Stuck In Stupid state.   

Perhaps its state machines don’t get reset in the right place when starting a new file.

It’s an interesting datapoint you bring up!


#13

In the meantime, you might try using MediaInfo on any suspect MKV file (hint: pirated file from the internet) before you try and play it on the Live.

Or – better yet – create files yourself, from material you own.  That way you won’t do anything stupid.


#14

The WDTV does hang up on certain files and then refuse to play others due an internal mechanism getting hung up as Tony said. However the solutions that were given were the correct ones. If you reset and unplug the WDTV it will forget this file. However if you then go on to play the file again then it will again hang up the unit and so on. If this happens to anybody and the unit hangs up twice assume that there is something wrong with that file and try another. We could have then looked at the mediainfo info of the bad file to see what was wrong with it. In short it seems that the WDTV has not got a very good exit route for ‘bad’ files and just hangs up.


#15

Ive also noticed that rebooting your computer (if you are using Network Share) seems to fix this hang up as well.