WD TV Live, version 1.01.24, Firmware Update


#21

Updated firmware fine, however these 2 YouTube bugs have not been fixed. Please see my idea for info and kudos it.

http://community.wdc.com/t5/WD-TV-Live-Ideas/Fix-YouTube-pause-video-bug-and-video-picture-cut-off-bug/idi-p/9741

Thanks


#22

It did not resolve the MP4 sync issue… :cry:

Also, some mp4 files cannot be played anymore…

Reboot at login to YouTube has been fixed. But watching YT videos is not my major use case I bought that device for.


#23

Nice to see an update that fixed the YouTube login reboot issue, but I would expected more fixes/enhancements. YouTube Channel Subscription feature is still not available and now certain videos cannot be played, so mixed feeling about this update. back to playing YouTube via PlayOn.


#24

MP4 audio sync is not resolved but it is, in my experience, much improved.

Files that had awful sync (whole seconds out) are now barely out of sync.  Reselecting the audio stream (Options) gets them back in sync.  FF and RW doesn’t seem to throw them out of sync either.  YMMV but for me this is a significant improvement and can almost see myself not having to remux everything into MKV files… almost.

There remains an issue with MP4 containers with AC3 audio not correctly passing the 6 channels out.  It’s down-mixing to Stereo or Pro Logic or something.  The same streams in an MKV container correctly make the journey to my receiver, so it’s not the encoding.  Surprised there’s not more noise being made about this.

-edit-

richUK has pointed out elsewhere that MP4 AC3 support is fairly new and that MP4 files with AC3 streams are likely non-standard, which seems reasonable enough.

The question remains: does the WDTVLive support the standard for MP4 / AC3?  I’m still looking into it; need to update YAMB to the latest beta just to create a compliant file.  :|


#25

I am glad to hear from PixelPower that the MP4 playback has been improved with this release.  I will apply this new firmware today.

On the other hand, I am kinda disappointed that the MP4’s AC3 downmixing issue still persists per PixelPower.  Well, most of my bluray rips are MKV anyway.

Does anyone know if USB hub works with this release yet?

Thanks!


#26

marzoqi wrote:

@whattheheck : I thought WDTVlive use same chip as seagate’s theater+ , while theater+ runs rmvb why isn’t wdtvlive unable to ?

I don’t know what chip the seagate is using, but the Lives chip can not play rmvb files.


#27

MetalHead wrote:

I am glad to hear from PixelPower that the MP4 playback has been improved with this release.  I will apply this new firmware today.

On the other hand, I am kinda disappointed that the MP4’s AC3 downmixing issue still persists per PixelPower.  Well, most of my bluray rips are MKV anyway.


Does anyone know if USB hub works with this release yet?


Thanks!


People, read the patch notes - they fix what is there not a million other problems.


#28

PixelPower wrote:

 

There remains an issue with MP4 containers with AC3 audio not correctly passing the 6 channels out.  It’s down-mixing to Stereo or Pro Logic or something.  The same streams in an MKV container correctly make the journey to my receiver, so it’s not the encoding.  Surprised there’s not more noise being made about this.

 

-edit-

 

richUK has pointed out elsewhere that MP4 AC3 support is fairly new and that MP4 files with AC3 streams are likely non-standard, which seems reasonable enough.

 

The question remains: does the WDTVLive support the standard for MP4 / AC3?  I’m still looking into it; need to update YAMB to the latest beta just to create a compliant file.  :|

 

 

From reading other forums it appears that ac3 is added to mp4 as a ‘private stream’ and this means that not everything has to support it. Other users have also had problems with ac3 in mp4 streams as they were not part of the original spec. Its doubtful that there are many hardware units which can decode these streams correctly. Obviously it is very easy to decode anything in software. On the other hand the mkv container is newer and does cover it.

http://trac.handbrake.fr/wiki/Containers

Comparison

  • In an MP4, you can store MPEG-4 video created by ffmpeg or x264. It stores audio in the AAC format. It is also possible to pass through Dolby Digital 5.1 Surround Sound (AC3) audio from a DVD in an MP4 file, although it is a new standard and not widely supported. Perian and VLC can decode it, and the AppleTV can pass it through to a surround sound receiver. 

a few comments I have found on other forums:

http://forum.handbrake.fr/viewtopic.php?f=6&t=14770&p=71213&hilit=ac3#p70658

http://www.avforums.com/forums/apple-computers-os-software/777390-ac3-passthrough-anyone-got-working.html


#29

Many thanks for the links and info.

I created what I assume is as compliant an AC3 MP4 as possible using the YAMB 2.1 beta.  Still no luck with playback; as you say, the WDTV Live as a hardware unit just doesn’t support it currently. 

Something else I found was remuxing MP4 files in YAMB is horribly slow and buggy.  Far quicker using MKVmerge GUI, which will then also produce an AC3 compliant file that plays perfectly on the Live.

Looks like I’m just going to abandon MP4 completely from now on.


#30

Was on .11, was holding off upgrading, finally did it this time.  No probs with the upgrade, Utube thing works now, nothat I really care, but now ALOT of my HD WMV files wont play, and some HD AVI’s also.  They ALL played fine last night :frowning:

For what its worth… wmv files codecs is WMV3 and the avi’s are mpeg4 divx5

Anyone else??

Gonna downgrade later tonight

EDIT - Nothing a reset didnt fix.  Hope this helps any else.  All is good now


#31

PixelPower wrote:

Many thanks for the links and info.

 

I created what I assume is as compliant an AC3 MP4 as possible using the YAMB 2.1 beta.  Still no luck with playback; as you say, the WDTV Live as a hardware unit just doesn’t support it currently. 

 

Something else I found was remuxing MP4 files in YAMB is horribly slow and buggy.  Far quicker using MKVmerge GUI, which will then also produce an AC3 compliant file that plays perfectly on the Live.

 

Looks like I’m just going to abandon MP4 completely from now on.

What are you encoding? Home movies? DVD collection? Try Handbrake or Mediacoder that both produce great mp4 or mkv files. Handbrake has an AC3 passthrough feature that makes encoding my DVD collection a breeze. I create an mkv file in Handbrake but then use tsmuxer to create an m2ts file, which is required to play on the PS3, but also works well on the Live.


#32

PLEASE PLEASE PLEASE!!!  Please make the “Next” and “Prev” jump to chapters–at least in MKV files!!


#33
Release 1.01.24 (2/9/10)

    * Implemented add to playlist feature in YouTube™.
    * Added Save search queries to save users time in re-entering search terms in YouTube.
    * Added seeking controls (fast forward/rewind) in the YouTube player in 10 second increments.
    * Fixed YouTube video list not presented in the same order as provided by YouTube server.
    * Added Flag Video feature to YouTube.
    * Updated to the new YouTube Video logo throughout the application.
    * Modified YouTube video timestamp format to make it more readable.
    * Redesigned YouTube user interface to comply with YouTube requirements.

AWESOME. Every update point was for YouTube. Who gives a root about the failures it has with networking and focus of noobtube!


#34

A new firmware is always welcome and the update went smoothly. 

However, HDMI to DVI Bug still exists.  The output is stuck at 480p no matter what resolution I choose.  I don’t understand why its taking them so long in fixing this problem.   Using the same cables, 1st gen wdtv had no problems forcing 720p or 1080p.  What is the point of this forum if not to fix problems.  This problem has been discussed numerous times in here and in different forums, but nobody is listening. 

If anyone from Western Digital is reading this, please fix this problem.


#35

jbloggs wrote:

Nice to see an update that fixed the YouTube login reboot issue, but I would expected more fixes/enhancements. YouTube Channel Subscription feature is still not available and now certain videos cannot be played, so mixed feeling about this update. back to playing YouTube via PlayOn.

http://community.wdc.com/t5/WD-TV-Live-Ideas/Access-to-YouTube-Channels-Subscriptions-alter-position-of/idi-p/222


#36

I’m the one who think WD make business with Youtube ???

This new firmware is a real nonsense, YouTube was not really the most important thing to fix right now !!!


#37

@__SD__: okay, the youtube upgrade policy is really strange.

but the update is not too bad. the fast forward and backward within videos works much better since 1.1.24


#38

bhwsyd wrote:

What are you encoding? Home movies? DVD collection? Try Handbrake or Mediacoder that both produce great mp4 or mkv files. Handbrake has an AC3 passthrough feature that makes encoding my DVD collection a breeze. I create an mkv file in Handbrake but then use tsmuxer to create an m2ts file, which is required to play on the PS3, but also works well on the Live.

DVDs mainly, bought a ridiculous amount back in my student days.  Not really begun encoding in earnest due to lack of storage.

Handbrake works well, and that’s what I’ve mainly been using.

The YAMB experiment was simply to try to create an MP4 file with AC3 audio that should have been compliant with the latest MP4 spec.  It still didn’t work on the WDTV Live so MP4 is not the optimal container if you actually want surround sound.

silvereyes wrote:

What is the point of this forum if not to fix problems. This problem has been discussed numerous times in here and in different forums, but nobody is listening. If anyone from Western Digital is reading this, please fix this problem.

This is a Community Support forum, keyword: ‘community’.  There are no WD techs reading these posts, just other WDTV owners like yourself.

If it’s not posted in the Ideas Lab, there’s no chance of it being seen by anyone who matters at WD.  Either contact tech support directly with a support ticket or create an idea in the Ideas Lab.  Otherwise you’re just preaching to the converted.  ;)


#39

I just purchased the WD TV LIVE to replace my WD TV.  After receiving the 2 firmware updates I am now at 1.01.24.  I’ve noticed that my VOB files sometimes don’t play in sequence.  This worked fine with the WD TV.  These files are on my local USB drive connected to the WD TV LIVE.  The 4 VOB files that make up a movie are in the same folder and numbered sequentially(standard).  Once I made it work after setting the Preview mode.  Anyone else with this problem?  Manual says it should work perfectly.  I noticed that the .TS file is not recognized.

Otherwise, I am very happy with this device.  I love the wireless capability.  It is compatible with many file types but alas some of my videos are not supported, I will have to detail these.  I have questions about DivX support.  My device reboots if I try to play a DivX purchased movie.  It plays the sound then dies.


#40

HD streaming from YouTube looks horrible like SD content . I never experienced this issue with the previous firmware. Do I have to change any setting to stream HD content. Could someone please help. Thanks WD