WD TV LIVE unable to play video files

Hello, I have the latest firmware instaled. Im unable to play any files at the moment, i get an error message saying " Unable to play selected file, Refer to user manual for list of files ( something close to this)" However the files tat it is unable to play are formats that usually work just fine. Tried downgrading formware, but faced ssame issue. Youtube or pandora don’t work either.  Tried resetting to no avail. If I unplug device for a minute and try playing video file, it works fine for a couple minutes. after about 10 minutes however if I try to stop/pause the video, the video stops but sound continues to play no mater which screen im on. If i try to go back to playthe ssame file or another video, I get the message again , " unable to play selected file, etc". UNit will only play again if unplauged. Files play fine on pc, ad as mentioned worked just fine before. Any suggestion would be appreciated.

Does the same problem happens with any type of video format or from any USB memory that you play the video from?

I get exactly the same bloody thing wont play files that it previously did and files it says it supports I like many others paid hard earned money for something that does not do what it is stated to be able to do. Trading standards issue here I think unless it gets sorted pretty bloody quick. I am really pissed off big time.

Same thing happened to me last night on both my SMPs - I  got the “unable to play selected file” message regardless of file type and how I tried to access file from the NAS (DS212). I restarted the NAS and both SMPs and currently can play all files again.  The SMPs ahve the latest firmware versions.

on further investigation, Nothing works after a couple minutes of viewing. Youtube plays for 2 minutes max, then the wait circle in the center of the screen keeps going. even if i come out that screen and try to go anywhere else to play anything ( video, youtube, radio, pandora) , I Find the circle in the middle of the screen going. It only leaves when unit is unplugged. After which everything work, but only for a few minutes.

Is there a fix, or is it time to toss it in the trash…

Magically since update no longer able to play mt2s files - my main reason to purchase.

Is there a way to step back versions?


Solved my own prob - removed power from WDTV Live, gave it the standard 10 secs then rebooted (powered it up)

Now plays mt2s & iso files again, wierd.