WD TV Live Streaming - lists only some of my media files

My WD TV Live Streaming box (f/w 1.06.04) only shows some of my media files within a directory- the rest do not show up regardless of file type or filename extension. This happens with both a USB stick or my DNS-323 NAS SMB/CIFS. It’s super frustrating.

Home->Files->Videos->Folders->(navigate to directory)-> see 32 folders (84 folders exist)
Home->Videos->Folders->(navigate to directory)-> see 32 folders (84 folders exist)

As a test I’ll rename a folder on the NAS, it then shows up on the WDTV Live with the new name, so it can see the update. All folders have the same permissions/properties.

The “Media Library” function seems… useless? I tried:
Home->Setup->Media Library->On or Clear Media Library
All this did was make the unit hang for several minutes, power LED blinking, “building media library” and when finished nothing’s changed.

Next I tried:
Home->Setup->Appearance->Show New Items->Within Past Year but still only 32 folders.

I tried cold-boots, resetting the unit to factory defaults and not sure what else to try.

Do you have also tried to switch the media library off? If so, are there still 32 folders? Select as source your local storage for testing.

I selected my NAS as my “media server”, or “local storage” when I triesd putting files on a USB stick.

Also trired with the “media library” feature turned off too. It made no difference

It’s like the WD box refuses to see some folders and files.

Do they start with a period or something? The wdtv ignores folders with a period at the beginning.

Turn off Upnp/dlna on your NAS if it is on.  I found that i could not locate and play many formats if the NAS was serving the data via upnp/dlna.  It acts better as a simple file share.  The WD then isn’t relying on the NAS to translate anything, the WD device can see and access almost anything.

The WD should be managing everything, the dlna/upnp is not what i would call a robust architecture yet.

Let me know if that helps.

I narrowed it down a bit, wasted another hour of my life with this box :smirk_cat:

First, from the Owner’s Manual, the WD Live TV Streaming requires WRITE access to your media server. I had this enabled but it is dangerous and a dumb requirement IMHO.

Setup-> Media Library->On->Media Library Manager->Set Autoscan -defaults to “During Standby Only”

I tried “Clear Media Library” then it said “Getting content info…” and power LED blinks and 20 minutes later it’s done. Yup 20 minutes later and it seems to have added thousands of files to my media server with .FQM and .metathumb filename extensions!? What a mess.

Still, a new movie on my NAS and it gets the .FQM/.metathumb files added but still does not show up anywhere on the WD.

I don’t know of a way to get the WD to reload the NAS directory without waiting…
Changed Autoscan to hourly, that’s the fastest option and no way I’m waiting 20 minutes to clear/rebuild the media library. It’s a useless feature that is making a mess.

I believe my original problem was I didn’t (know to) wait for the WD to take 20 minutes “getting content info” and so I think I got a PARTIAL listing.

I just disabled UPnP on my NAS and will see if that helps, and I think I’ll turn off the WD media library, it’s unusable.

FQM files from the WD? I don’t think so…

sorry it’s .xml (and .metathumb files) the Media Library seems to create, and then there’s a database inside a wdlive folder.

Anyhow, how can I get the WD to update it’s file listing of my media server?

I’m tired of new files on my media server not showing up on the WD box unless I “clear media library” and wait 20 minutes to rebuild it. UPnp on or off does not matter.

UPnP has nothing to do with it, btw…

All you need to do is “RESCAN” the folder that contains the changes you’ve made.

Highlight the folder, then OPTIONS --> RESCAN.