WD TV Live Streaming configuration with QNAP NAS... help needed please

Hope you could help me with that problem…

QNAP attached to my network…

WD TV Live attached wired to my network…

When I select VIDEOS / Network share / Linux Shares… in the next screen “Select content source: Linux Shares”… I have the disc spinning searching forever without success… What I’m missing… please… thanks… Frank.

Have you enabled NFS in the QNAP? In the QNAP go to Network Services -> NFS service and enable.

Secondly to that, you need to sure under your share setup that you have the NFS permissions set properly (full access). Each share has a button to set the NFS permission.

Thanks… worked like a charm !

Now I have a bunch of folders… Download - Multimedia - Network recycle Bin 1 - Public - Recordings - Usb - Web… I just want to see the “Multimedia” folder… which have all my movie genre folders in it… the other ones I don’t want them to appear at all… Thanks in advance, Frank.

Frank, you can ignore my PM since you already got the answer.

But as to why you see ALL the shares:   That’s a QNAP bug, really.   Both of mine do the same thing.

The WDTVs use the “showmount” command in Linux to find the exported volumes.   An NFS server should ONLY list the ones that ARE exported (ie, for which you’ve enabled NFS), and should also list the ACCESS LIST (the IP addresses that are allowed.)

But the QNAPs don’t do this.   They just provide the entire volume listing.

The WD could technically get around this by attempting to actually MOUNT every share and only display the ones for which it was successful, but it shouldn’t be necessary…

I enabled NFS only for the MULTIMEDIA folder… I tried to modify permissions… nothing works for that… I still see all the folders instead of just the MULTIMEDIA one… for me it’s ok… but for my kid and girlfriend it can be confusing…they have to select multimedia first… the best thing will be to see only the content of multimedia…not even that folder or the other ones… that would be the best when choosing VIDEOS… any clues to do that… anyone… with the QNAP… otherwise I’ll have to live with that.

As I said above, it’s a QNAP bug. Nothing you can do to get around it.