WD TV Live stops playing files

No cable, modem/router switched off. The device has zero connection to a network of any kind. It’s the only way it will play local files without crashing.

fwiw, I’ve had my WD TV live streaming player for more than a year (I did update to current FW last September).  One afternoon last week, I suddenly encountered the same issue where existing MP4 and MKV files would not play beyond about 30 minutes.

The files were stored on a flash drive plugged into USB socket.  I tried a different flash drive with same results.

This had me completely baffled.  The WD TV box was not overheating.  Rebooting it didn’t make any difference.  The issue persisted all afternoon.

The box is connected to the network via wifi and I do have a DLNA server (shibby tomato access point with flash drive connected).  I switched off the server and rebooted the WD box and it didn’t make any difference.

I then did some googling and came across old posts  in this forum that seem to suggest when WD box unexpectedly becoming the new master browser,  this can cause video playback issues even from USB if the box is connected to the network.

I then realised I had a Windows 8.1 laptop switched on  (sleep mode disabled) since the morning and had forgotten to switch it off.   I turned off the laptop, and also rebooted the WD box and the problem with videos halting after about half an hour disappeared.  Media streaming (DLNA) is Not enabled on the win 8.1 laptop and I’ve never seen the laptop appear in list of DLNA servers on the WD box when I have been using it for past year when the laptop has been left on btw.

I’ve not been able to reproduce the problem with the laptop turned on.

I also have  WD MyNet N750 router which I have not rebooted in 6 months.   I did not reboot the router while investigating the above problem.  The N750 can act as a secondary browser - the ‘Master Browser’ setting was unchecked.  As a precation, I’ve now checked the setting to make sure the router is always the Master Browser.  I have no idea if it will make any difference in long run.  The N750 can also double as a DLNA server and it is visible to the WD TV Live box, but I never use it as MKV files won’t play from it (known bug) and there is no way of permanently disabling it.

I don’t know if it is Master Browser related, but I thought I’d share my observations.

NightmareRunner wrote:


Scenario B - When playing videos off of a USB device while TV Live is NOT CONNECTED to the internet the system works perfectly fine and I can watch videos back to back with zero freezing.



if it works when the WD is not connected to network (ie no eithernet and no wifi connection)

then the problem is on the network, most likely DNLA related

on other news techflaws mentioned above, we’re working on a way to get some debugging output

@techflaws, I think I found a way to debug only the medialogic portion without dmaosd

I’ll test it tonight, then send you a PM with the info when I’m done testing

As a followup to my issues relating to the BBC iPlayer, I’m working with WD support on the issue who have been great so far.

I’ll post back if I get anything tangible to share.

Sounds positive on the debugging output front… 

Some additional info:

I’ve also verified that the two other BBC apps/services on the WDTV Live, namely “BBC News” and “BBC Sport” both also cause the bug that breaks media playback, and is 100% reproducible too.

I don’t know whether those and the iPlayer app are developed by the same team, and/or use shared code or something, but they all break mdia playback after use so something is going on between the BBC apps and the WDTV 2.02.32 firmware version.

WD are aware of this and are looking into it, hopefully we’ll get a fix at some point.

hey guys, just a quick little update

since I mentioned logging

I got some limited logging functions working on official firmware

the bad news is that the logging really did not provide anything useful

but I’ve still got something pending on this

and no it’s not a cure all

but it may help some people

so stay tuned

hey you might want to check this out


I could have written that myself!!

My box is acting the same way exactly.

It stated off with an “Out of memory” message when playing videos and has now got to the stage that to play any different file types (which have played for years before) you have to do a shutdown and restart of the box.

I’ve tried rolling back the firmware three generations but this has not cured the problem.

I’ve also got one of the earlier versions of the WD box which still functions perfectly.

It looks like it’s getting to the end of the road for the WD TV Live in our house as a new Android MX111 box is on its way.

This will do 4k video and play 50fps video which the WD falls down on as it can’t keep up with the video and the audio together resulting in broken-up sound.

Such a pity after some years of good service.

Ok, I’ve just heard back from WD about the bug with the BBC apps breaking media playback, and their engineers have indeed confirmed it is a firmware issue.

I don’t know whether they will include a fix for this in a future firmware version, but hopefully they will - at least they know about it now. In the meantime, it can go on the official list of firmware bugs with the WD TV Live current firmware version, and anyone else who comes across the bug will hopefully stumble upon this thread.

If we get a new firmware version at some point, I’ll check to see if it fixes the behaviour and update the thread.