WD TV Live stopped working after a week (only the LED light is burning)


Last week, I received my WD TV Live mediaplayer.  I had unboxed it, installed it and it worked fine.

It connected to internet, could access through a share, services worked etc.  So no issues.

Yesterday, I was reorganising some cabling and was going to give it a more definitive setup and after I finished and everything was plugged in again, I only got the white LED light on the front of the mediaplayer but nothing else…

It’s not found back anymore on my network, it’s not recognised anymore through the HDMI cable nor with the composite cable that was delivered with it.

I tried a few times to plug out the power and plugging it back in, but no change.  

I tried the reset button on the side but also no change.

Are there any ways to test if there is still something going on in the player?

I did nothing that could have damaged it in any way during the switching of the cables.  

Unplugged the device and just plugged it in again after all my cabling organisation was finished.

Any advices?  Otherwise, I will have to return it and hope I get a replacement.

You’re in the wrong forum for the new Live player…but anyway…is there a reset button or hole to stick a paperclip in or anything like that on the new model?  If so, did you try it?

Hi thx for the quick reply.  I did not see any notice of the version of the player in this forum so I thought it was the correct one.

Anyhow, yes, there is a reset button in a small hole on the bottom.  And I tried this one with a toothpick.

Felt the button click but nothing happened…

The forum for the 2011 WDTV Live Streaming Media Player is here:


I suppose it’s possible that a static discharge may have damaged it, or, it just simply “failed.”  If it’s new, just exchange it for a new one.