WD TV Live stopped playing some video files?

Hey everyone :smiley:

OK, here’s the deal.

About a year ago I bought a WD TV Live Network Media Player from an online PC store.


At the beginning everything worked fine but now I am experiencing some problems with movie playback. For some reason it just stopped playing certain movie files (mostly .avi-s). I know some of you would think that there is an issue with the codec support but that’s not it. The movies it stopped playing are the same movies that worked fine before.

The system:

  • WD media player connected to my TV and NOT connected to a network.

  • USB1: WD My Passport Essential SE (1TB) external drive with password protection

  • USB2: WD Elements (750GB) external drive


Issue details:

  1. I select a movie


  1. I start a movie


  1. The load screen appears but the movie won’t start. The screen just stays black.


  1. Then when I cancel this movie and try to play any other movie, this is what happens and it stays like this until I turn the player off.


I would really apreciate any help with this.

cheers :smiley:

Have you try doing a factory restore?


Yes, I have just now tried it and it didn’t work.

thanks anyway.