WD TV Live stopped playing after 10mins

  • WD TV Live Streaming

  • WD MyBook Live

  • D-Link DIR-655 Wireless N Router

All are with latest version of firmware

I have no problem with playing 720p mkv video on Wi-Fi, via Samba or TwonkyMedia. But the problem is, it stopped playing after about 10mins, always, WD TV Live looks like frozen or hung something, the only way to get it back is to power off and then on.

I Googled and did find something interesting in this forum and other forums, some posts do help, actually I ‘solved’ this issue, somehow. One post mentioned to disable UPnP port forwarding on NAS itself. Since there is no such option on MyBook Live, I checked wireless router and disabled UPnP feature from there. It worked! I no longer encountered this issue.

However when I check MyBook Live WebUI, under remote connection page, I noticed WD suggested trunning on UPnP on router to get a better performance else it will be using relay…

I am a bit confused and just wondering why WD made such suggestion because it does NOT work and should do the other way rounf? Did they really test WD TV Live with MyBook Live?

MyBook Live is looking for UPnP enabled on router, so what is this UPnP forwarding actually doing? What does it help when it is enabled?

In theory, enabling the UPnP will allow any device that you connect to your network, auto negotiate and auto configure, thus, connect automatically to your network.