[WD TV LIVE SMP] Unable to Delete Files!

Hi guys currently having a problem where i am unable to delete any files created by my WD TV LIVE SMP eg: .wd_tv folders

My Current Setup is:

WD TV LIVE SMP Firmware 1.07.15

NAS > Dlink DNS-320

Windows 7 Ultimate N 64

When  ever i try to delete a file using Windows Explorer on my PC it gives the error

20120329162030655.jpeg

I have read else where that they recommend accessing the files from the NAS WebUI to delete it, but as far as i know the DNS-320 doesnt have such a facility to delete files from the WebUI

Anyone knows? i keep hearing people saying that i should telnet in and delete the file? How exactly do i do that is there any othe alternatives

This was one of my my previous problems as described here, but didn’t mention before:

http://community.wdc.com/t5/WD-TV-Live-Streaming-Discussions/ISO-Causes-Random-Lockup-Reboot/m-p/379707#M7170

I think (but am not sure) that me (and you) did disconnect the drive during the green LED light blinking of the TV Live box. In that case the box is writing to your harddrive and become corrupt if you disconnect the drive during writing. My solution was to make a backup of the total drive to another drive and re-format the drive with the files that could not be deleted first.

With the work around in my previous message in the above link I have met   no trouble since.

  • Always take your time to do anything till the green LED light stops blinking.

  • Always switch off the TV Live box first (and no blinking of the green LED) before disconnecting the external drive.

If the file is locked by some windows process you could try accessing your source as Linux share (works with myBook live- depends on your setup)

This way I was able to delete several locked files…

edit - sorry - just realized that you were talking about files created BY the wdtv …so you won’t be able to access them though the wdtv interface…then maybe telnet or try what the previous poster said…good luck :wink:

Make sure WDTV is not acessing the file.

For example, EJECT the drive (or turn off WDTV and after that turn off WDTV power cable).

The error says, you cant delete the file, because you dont have permisson.

Make sure you login in windows as administrator.

Try to delete the file now.

If that still doesn’t work, take ownership of the file.

How to take ownership of a file: http://technet.microsoft.com/en-us/library/cc753659.aspx

If  you find MS intructions complex, google how to take ownership of a file in windows.

PS: It’s really a bad thing that WDTV needs write permission to all shares and local drives. I can only hope they FIX this.

Thanks for the suggestions guys i have managed to delete the files by using my DNS-320 (NAS) web file server. Still oculdnt do it via windows though.

Had this problem today but solved it this way. 

I selected the folder to be removed from the WDTV HDD and right clicked “Cut”.  Went to my desktop and clicked “Paste” onto my PC desktop. It pasted there OK. I noticed the folder on the WDTV attached HDD was still there.  Now I was able to select and delete the folder on the HDD without a problem. 

Then I deleted the “Cut” folder from my PC desktop.