WD TV Live SMP plays one video from local network or PlayOn and then needs to be restarted

The title does have most of the issue wrapped up, but let me explain with some pertinent details.

I have a wired gigabit network throughout my home and wireless-b/g/n as well.  I have a Synology DS411+ sharing out videos, music and photos as well as a Seagate BlackArmor 1TB NAS doing some of the same.  I have two lifetime Playon.tv accounts, a Netflix account and a Hulu Plus account.  I own two other streaming video devices as well (neither are turned on at the moment OR during any of these issue) - the Netgear EVA2000 and the Roku 2 XS.  Strange as this may sound - the ‘defunct and unsupported’ Netgear has been my most reliable device.

I recently (within the last 7 days) purchased the WD TV Live Streaming Media Player because I had before (a month ago or a little less) gotten the Roku 2 XS and found it to be a bit annoying at times (again - compared to my older Netgear EVA 2000) and was trying to figure out which device might work best for me given my wide variety of media options and the output capabilities of the Netgear being somewhat limited.

Anyway - when I connected (wired network) the WD TV Live Streaming Media Player it seemingly found everything. I was elated because with the Roku 2, I had to install a PlayOn Channel and even ended up installing a Plex server on my Synology DS411+ so I could stream local media and so on.  The WD box seemed to not only just find all my media servers without any setup (PlayOn, the Synology box, the BA NAS, etc.) but it has a pretty friendly interface with OPTIONS on the views.  Fantastic I thought.

Then I selected PlayOn and started streaming a video from one of my channels (Hulu, Netflix, CBS, Comedy Central, SyFy Rewind, etc. - the channel ended up being unimportant) and it played.  No weird hiccups like the Roku 2 had - where I might have to exit and go back into the playing video or pause for 30+ seconds to make sure it streamed okay.  It just played.  I was happy and watched my video.  It got to the end and … just sat on a black screen.  I pressed stop.  Nothing.  I pressed “Back” and it went back to the selection screen for whatever channel in PlayOn I was when I selected the last video to play.  I shrugged it off - thinking all devices have their quirks.  I chose another video from PlayOn - one from the same channel.  It came up with the spinning orange/tan circle and just sat there like that.  I let it sit for about 2 minutes before hitting BACK and trying another video, different channel.  Same result.  So then I exited PlayOn Channels and decided to just stream from the Synology box.  Same issue.

At this point I wasn’t all that frustrated.  I figured maybe I needed to upgrade the firmware - and I did.  SO I upgraded, restarted, checked again and upgraded, restarted and checked again - finally I was at the latest firmware revision (1.03.10).

I tried playing a video from the Synology first this time (In this case an AVI, I also have TS and MKVs and MP4s and a few others…)  It worked. So I stopped the video, chose another and…  Orange spinning - no video.  Went to PlayOn, orange spinning, no video.

So I thought about the built in services.  Those still worked.  The built-in Hulu Plus, the built-in Netflix - all still played.  However - this is not all I use - I also use PlayOn and my pretty large collection of movies and television shows I ripped from my DVD’s/etc. off the two network attached devices.

_ I have found that if I play a local/playon.tv video and then restarted the box - I could then play another… and so on.  It works - as long as I reboot in-between playing the local/streaming media as described above. _  The WD TV Live Streaming Media Player doesn’t take all THAT long to restart - but… c’mon.  Yes - the built-in stuff works continuously (Netflix, Hulu Plus, etc.)  However I thought one of the big selling points of this box was how well it played the various formats someone might have on their home systems…

I do not experience this with the Netgear box.  I do not experience this with the Roku 2.  I really like the WD box’s interface options more than the other two.  I think its remote could have been RF instead of infrared and worked a little better (small box, small target, many possible angles.)  The remote issue of mine is small and easily workable.  This rebooting the box after every Playon.TV or local streaming video - that is not so easily accepted.

I have tried resetting the box in every way it can be (leaving the various parts and getting rid of everything I customized) and none of them have fixed the problem.  I changed the way it was connected to the projector, changed the output device to a television instead of the projector, switched power outlets/strips, changed out cables going from the device to the various output devices, etc.

  • Is this a defective box?
  • Has anyone heard of this issue before?
  • Is there something I can do or something I can try to keep from having to restart between videos?
  • If it has to be swapped out, how difficult is it to get done?  (Is there a specific place to go to get instructions?)
  • Is anyone else using this box (or another WD TV product) with Playon.TV?  (Without issues?)
  • Same as the last, substituting in “Synology box” for “Playon.TV” and/or “Seagate BA NAS” for “Playon.TV”…?

Any suggestions welcome.

If I am doing something stupid or expecting this box to do something it shouldn’t - call me on it.

I just want the answer and/or a list of things to try.

I’d rather keep the box - return it for a new one if necessary - but I like the little device, it has potential and I really do like the interface.  I am working, of course, under the assumption that I am not expecting it to do things it cannot do.  Since the other two boxes I have - albeit they both have their quirks and took their own special tweaks to get them to do everything I wanted within their own capabilities - can do what I am expecting this WD TV Live Streaming Media Player to do… I don’t see why this box cannot do it too (without the watch/restart/watch/restart/rinse/repeat thing.)

Hmmm.   I was using Playon the other night watching my Amazon Prime stuff, and didn’t experience that issue.

However, it wasn’t the FIRST thing I played after a reboot.

I’ll see if I can reproduce this by following your steps.

Forgot one thing (at least):

PlayOn v3.4.25.2572

I have a similar setup.

  1. 1TB drive attatched  via local usb to WDTV live with .mts/.m2ts files

  2. windows XP box serving other additional media  with a Play-On server running

tried the following

  1. watched a local mt2s file served from the USB drive…Paused after 5min

  2. switched to PlayOn  media server,selected some clips to watch from various channels. Jon Stewart/Mencia/Seinfield…watched  each for a couple of minutes.

  3. went back to local m2ts file as in 1) …no problems… WDTV offered to either “Resume” or “Restart”…Resume worked


Didn’t play anything to completion,had no problems switching  between sources.

I don’t recall if  PlayOn actually supports WDTV. I’ve had some trouble with certain channels/media and found it to

be “unpredictable”. I don’t know what is actually does in terms of transcoding.(My XP box doing the serving is only

Atom525 powered.) At one point I had a “request/suggestion” to PlayOn to have it simply serve the stream from the

channel directly to the WDTV… which should be capable of handling the compressed stream.

I can’t remember their reply now,but there is some complexity/mixed formatting in the stream that makes this messy

so PlayOn need to do some kind of transcoding.

…Something of a digression,but thats my experience with PlayOn…I rarely use it now and don’t want to build/buy a

box with more processing power.

Yeah, I tried again last night and didn’t have any issues like that.  

I did more testing - thinking it might be computer related or installation of the OS/drivers/etc related (considering how PlayOn works…

I installed PlayOn on another machine, started it up and found the same problem.  I had a spare hard drive and started installing a clean system that will have nothing but what is necessary to run PlayOn to see if it is a system issue.

Here’s an interesting twist with PlayOn; if I play for less than, for example, five minutes - it will go back to the show selection screen and continue to work, meaning I can play the next video.  I can get that result for short clips or just by stopping the video shortly into it/pressing the back button.  If, however, I allow the video to play through (for example - the ‘30 minute’ type shows) - when I get to the end it just shows a black screen.  I have to click on BACK to get to the list of shows and trying to play the next video is unsuccessful.  Also - if I use the WD box to go to the HULU PLUS service (built-in functionality) and start to play that same video… It asks if I want to resume play or restart and if I resume - it is close but not at the end of the video.  It almosts sounds like a buffering thing - that if I had waited the extra 10 minutes or whatever on that black screen, it would have quit back to the show selection screen on its own and worked.

The same ~5 minute rule applies to the playing of streaming video off the Synology box and Seagate BlackArmor NAS.  Once the issue shows itself - only the services work - the Files or Video options for my local notwork (PlayOn, Synology or BA NAS) all just result in a spinning orange arrow UNTIL I restart.

So the two things I have left to try…

  1. Finish the clean install of PlayOn on the cleanly installed (minimal software) system.  Try that through the WD box.

  2. Plug in the wireless USB device and get it working on the WD box - although I cannot see that making a difference (in my eyes - that could make things worse. hah)

After that - I think I will have to resolve myself to contact WD support and see about getting a new box sent out or returning this one to Amazon/TigerDirect for a refund.  I really hate to do that - as out of the three boxes I have - I like its interface the best.


I appreciate the testing you did.  I am beginning to resign myself to the HOPE that it is a defective box of some sort.  Since I can swap it with either of my other two boxes and they do not show these symptoms - and others (like yourself) are not having this issue…


Thanks for trying!  I still need to figure out what to do - but having someone else try it out helps eliminate possibilities!


One other experiment to try…?

Do you have any other machine more powerful than a Synology/Seagate box… AFAI recall these are Atom powered.

( I suspect there is something going on with the transcoding that PlayOn is doing…depending on the channel source.)

If you do try installing it on that machine and see how that works.

I just dug some e-mail thread with tech support from  ~ 1yr ago…

Q)    I would like to be able to tell PlayOn not to do any transcoding,but simply hand-off/ transfer this stream to the
   WDTV live and have the WDTV live do the transcoding of this real-time stream.

A1) Your devices do not have any way to play Flash videos, so the transcoding is necessary.  If you are referring to the My Media channel then you can choose to not transcode the files, but you won’t be able to do this until My Media leaves beta.  The My Media channel is the only channel that is transcoding a file type supported by the WDTV Live or most any other devices.

A2) I am happy to assist you today.  I do understand your question and that, would indeed be a nice feature.  Unfortunately there is currently no way to configure PlayOn to turn off transcoding.  That may be an option available in the future, but no guarantees or timeline as of yet.

…Not sure I fully understand answer 1)

I think there is still some misunderstanding about my setup.  Although I use the Synology and Seagate BlackArmor boxes as DLNA devices (and have installed “Plex” [http://plexapp.com/] on my Synology box so I could stream local content with my ROKU 2 XS - and you are correct in that I cannot stream local content over 720p without experiencing some issues) - I do not have PlayOn installed on either of those NAS boxes.

PlayOn is installed on two different computers with two different licenses.  Each have Quad Core 3.2+GHz processors with a minimum of 4GB of memory.  Neither have problems pumping out PlayOn content over wired or wireless connections for the NetGear EVA2000 box or the ROKU 2 XS box (and the Netgear isn’t doing much of anything on its own.)

All it takes is one 5+ minute video played from Hulu and then no ‘local media server’ option will play anything (I can browse all I want, just get the orange spinning circle when I play.)

So, essentially on one end of the spectrum I have two different computers (some specs above) running PlayOn (two different Premium licenses and setups)  and also a Synology DS411+ box serving video/music/pictures as well as a BlackArmor NAS 1TB with some video and pictures on it.  All of that is connected to a 1Gbps network (wired) and thus available over the 802.11n (wireless) in the home as well.  On the other end is the three boxes (Netgear EVA2000, ROKU 2 XS and WD TV Live Streaming Media Player) and only the WD has trouble playing the media from PlayOn and/or local streaming.  The ROKU required some channel  additions and extra setup (Plex and PlayOn Channels and a Plex Server installed and made for Intel-based Synology boxes.)  The Netgear EVA2000 has just worked with everything so far… It is just limited on resolution and hasn’t been supported for some time now.

I have hooked up the Netgear EVA2000 and Roku 2 XS both wired and wireless without any issues there.  I have only hooked the WD TV Live box up via wired connectivity so far (albeit a wire both the other two boxes have used in the past - in fact - the WD TV Live box is physically sitting on top of the Netgear EVA2000 box - which is completely unplugged form network and power.)

I have reset the WD TV Live box and tried three different  firmware (Original, first upgrade and current firmware version) revisions and all have resulted in the “single-play, must restart the WD TV Live box to play another Media Server video” issue.

I installed a clean version Windows 7 64-bit operating system on one of the two computers that have PlayOn on them (dual-boot.)  It basically has PlayOn, VLC, the latest drivers for the hardware and… that’s it.  Same issues.

Given everything works on the ROKU 2 XS and Netgear EVA2000 - I am having trouble coming to any other conclusion than something is wrong with the WD TV Live Streaming Media Player device (at least the one I have.)  I really want it to work - it’s interface is worlds above that of the other two boxes mentioned and the number of formats it plays natively - nice.

Try it from a different angle, if you haven’t already.

Try shutting down *EVERYTHING* on your network, except for a SINGLE SERVER.

See if the problem is reproducable with the bare minimum equipment.

If it’s NOT reproducible, then turn on another devices, etc. etc.

See if you can narrow down if there may be possible interference from another device.

There is a very mysterious bug that seems to affect ALL WD devices, but only for a very small number of people:   SOMETHING on their network causes various malfunctions.  

What it sounds like in your case is that the “renderer” process on the WD is crashing.  The symptoms are described in a KBA article, and exactly describe your symptoms.    But the KBA article deals with UNSUPPORTED media, but the symptoms are the same regardless of WHY the renderer crashes…

Same issue here using PlayOn.

Only way out is to restart WDTV SMB. PlayOn works fine on Samsung BD c5500.

Running latest PlayON and lastest WD firmware.

The suggestion to disconnect everything but essentially two devices from my network has, at this point, narrowed things down GREATLY.  It took a while because I wanted thorough tests and because I don’t just have 3 or 4 items on my network.  *grin*

I do have a set of Netgear Powerline networking devices that sits on my network to connect the Seagate BlackArmor NAS and the attached HP 1215 Color Laser printer because they happen to be in an ‘inconvenient’ place in terms of networking (although I may drop a line to them since the speed of the powerline network combined with the issue it may be causing here pretty much closes that case) and when that ‘circuit’ of my network is disconnected - the problem no longer exists.  One cable going from the router to the powerline network and everything goes south.  I don’t think it is the Seagate NAS nor the printer - but honestly - have not tested that yet.

Everything else can seemingly be connected and the Western Digital box works with PlayOn and the Synology NAS as it should - smooth and happy.

Bizarre how the other two devices do not have this problem, but as I said, I will probably eliminate the ‘weird’ circuit by just dropping a network line in place.

I really appreciate the discussion and attention my small problem got.  Thank you for all your suggestions and listening to me gripe.

Hopefully someone else might come across this and have some of the same devices (Netgear XE104 85Mbps Wall-Plugged Ethernet Switch) on their network and avoid having to disconnect 10+ items and testing the connection while they add back one at a time, rebooting and trying again… And doing it all over time to make sure they play the video(s) long enough, etc.