WD TV Live SMP does not recognize local HDD - Help please!

I have a 4 TB Seagate HDD which continues to not be recognized when plugged into the WD TV Live SMP. I’ve scowered these forums and have found many other threads with people offering various tips, and thus far none of them has worked for me.

I have disabled the media library, I have plugged the drive directly into the wall outlet I have tried plugging it into both USB ports on the player, and stil nothing has worked. I’ve formatted the drive numerous times using both NTFS & HFS+ (non journaled), and nothing I’ve done seems to help resolve the problem.

When I plug the drive into my Macbook Pro, it is absoulty fine with access to both read and write. I’ve used Disc Utility to verify that there aren’t any problems on the disc itself, and the results come back that the file structure is indeed fine. I’ve even just finished running a low level format on it, and still, the WD TV Live SMP willl not recognize the drive.

I have emailed WD Tech Support, and It took over a week to hear back from them, with their first troubleshooting suggestion being to plug the HDD directly into the wall outlet, which I had already tried. I emailed them back explaining all of the above information, and it’s been 3 days without a response.

I also asked them to verify whether or not the WD TV Live “offically” supports 4TB HDD. I’ve yet to find ANY documentation in either their manuels, or on their website, that claims it does. I’ve seen on these forums that people have had success, and I was even told over the phone by a WD support staff that it does, but I haven’t been able to find anything in writing that also says this.

The only documentation that I’ve found which offically outlines compatible HDD’s, is the link below.


As far as I could tell, none of these drives are actually 3-4 TB in size. I could be wrong on that, but in my last email to WD Tech Support, I did ask them to clarify if indeed any of them were 4 TB in size, and if not, which drives of that size are compaitble.

I have to admit, I’m quite frustrated by how long it’s taken to get help for the product. I really would like to be able to use it, however, If I can’t get an answer on how to solve the problem, or, be given an officially endorsed HDD, than I will likely return the unit.

Are there any WD employees on here or frequent members that can help me?


Have you tried with a single GPT partition?

I have, yes.

I currently have the drive formatted using NTFS however.

Not sure if SMP can use GPT-formatted drives.  Support for GPT is a Linux kernel option so need not have been enabled in the SMP kernel.

However, 4 TB drives require GPT only if they use 512-byte sectors.  The so-called “2 TB limit” for MBR formatted drives applies only if the drive uses 512B sectors (the limit is 32-bit words for sectors).  Many >2 TB drives actually use 4kB (4096B) sectors, so can continue to work with MBR formatting.  E.g., all my 3 TB drives report 4k sectors, and all are MBR formatted, as one 3 TB MBR partition.  (All these 3 TB drives are Seagate BTW.)

So I would suggest  you check what your 4 TB drive reports for sector size, and if it is 4k/4096, try formatting using MBR scheme.  (If you have already tried this and it did not work, I would have no idea why that might be.)

My research has shown that the WD TV Live SMP does indeed support GPT.

My drive does indeed have a 4K sector size, and as you’ve suggested, I have tried it using a MBR. Unfortunatly it has not worked.

Currently it’s formatted to NTFS using a GUID (GPT) partition table.