WD TV Live Problem

When I run WD TV Live it runs perfectly (via Wi-fi) and does everything I expect.  Use services, show photos off of my computer, etc., etc.  Runs great. Love it.

My computer is running Windows 7 and I use Internet Explorer 10 as a browser.

I only use the WD TV Live infrequently; so, when I’m not using it I shut it off and cut the power to it.

After that, when I go back to the computer and try to browse with IE10, the browser loads and then shows it is waiting for the target internet site and just stalls–blank white page.  The only way I can recover is to run a “fix-it” on Internet Explorer 10.  Then it once again it runs fine.

The problem is not the router because after turning WD TV Live off, I can readily use email from the computer–it’s just doing something that blocks Internet Explorer 10.

I’ve not been able to figure out what is blocking Internet Explorer 10 after the use of WD TV Live.

Any solution you might have is appreciated.


What happens if you power off your WD player and then reboot your PC. 

What is this ‘fix-it’ that gets it working.

Have you tried another web browser.

Microsoft has an automatic fix as part of it’s fix-it programs.

This one is at:


Did you try the reboot of your PC to see if that cured the problem.

Rebooting the computer usually makes IE operable again but often only to visit a net site or two–then it stalls again.  If I reboot the computer and IE is working and then I run the fix-it, it stays operable–but only until the next time I powerup and use WD TV Live again.  Following the WD TV Live use, I have to reboot the computer to getr IE working and go thru the same routine again.  I might add that I have a laptop running on Wifi with Windows 8 and it never has any issues under the same circumstaance with IE 10.

After a WD TV Session, I only have this problem on the Windows 7 desktop but no issues with the Windows 8 laptop.

The Windows 7 desktop is wired to the router.

I might add, I have a thumb drive in the WD TV unit wih has a few photos I use as a screen saver on it.  The thumb drive was mapped to Windows 7 computer and , later, “unmapped”.

I reinstalled IE10.but have the same issue with both IE9 and IE10.  Here’s where I’m at:

If I use WD TV Live and later go to my computer, I can access my email; but, if I try to use a browser and access the internet, the browser loads, waits for a reply from the target site and just sits there --stalled with a blank screen.

Now, it is simpler to get it going; but the only way I can is to reboot the computer which is a pain in the neck.

Please add any thoughts you might I have to help me fix this and avoid rebooting my computer after every time I use WD TV LIve.

Given the fact that it’s Micros~1 we’re talking about, I’m quite sure the problem is on their end. I see no way how a WDTV in the network would possibly interfer with the OS’s address resolution. What happens with Firefox/Opera?

Techflaws wrote:

Given the fact that it’s Micros~1 we’re talking about, I’m quite sure the problem is on their end. I see no way how a WDTV in the network would possibly interfer with the OS’s address resolution. What happens with Firefox/Opera?

I tend to agree with you.  It’s a big stretch to blame browser issues on a WDTV (or any other external hardware for that matter).  Could be a router out of whack somehow, as that is the only thing shared by the PC and the WDTV.

I wonder if the 'puter in question is a “homemade” one with Win installed by user. 

If the router and modem have not been rebooted, I would try that.

The computer is a 1 year old HP p7-1241 with factory installed Windows 7 with all updates maintained.

The router/modem is a brand new Verizon Actiontec M1424Wr Rev1.

Following use of the WD TV LIve my computer works fine, I can even send and recieve email; but I cannot access the internet as IE10 (and IE9 also) just stalls on a blank screen.

Resetting the modem router does not solve the problem.

The only thing that solves the issue is rebooting the computer.

If I do not use WD TV Live, everything runs great as I long as I continue to not use WD TV Live; but, just once used, when I go back to the computer, I will have to reboot the computer.

Your router may be “new”, but if it is not set up properly in some way, it could cause problems.  Don’t mess with it if you haven’t the experience.

I suggest you install and try another browser (e.g. Chrome, the second most popular one) and see how things go.

It just doesn’t seem possible or logical that a WDTV can screw up a PC browser’s proper operation.  We are talking oil and water here, and not apples and oranges.

Three other computers, mine and those of other folks, have operated and do operate  off of this router at various times without incident.

I’d like to stick with IE as browser for the time being and will continue to search for a solution.

The computer with the glitch is the only one running Windows 7; and, while I don’t yet totally understand it, I’m beginning to think the issue may have to do with Windows “Data Execution Prevention” (DEP) and the interaction between WD TV Live and DEP.

I appreciate your help and anyone else’s contributions.

I prefer IE as a browser, too, but I HAD to install Chrome, because some of the websites I visit did not work  any more because the websites were using HTML5 and IE 9 can’t handle it.  I have not yet installed IE 10, so I don’t know if it has been “modernized” enough for the problems with HTML5 are gone.  It’s been out a while now, so maybe it is safe to try it.

If you only have issues with the browser on the Win 7 PC (and WDTV) and not the others, then the problem lies with the Win 7 PC.

DEP has been known to cause so problems with the excecution of certain software. Still don’t know how it should be affected by the WDTV being on the network. Also, my combination of Win7 and WDTV runs just fine.

Poster: You have a new WDTV, and I suggest you get help from WD support for your new unit.  Give them a call.

Already did contact WD. Now waiting on their reply.

I suggest you CALL them, not write them.

WD support responded quickly to my problem.

On their advice, I rolled the firmware back to version 1.15.10.

Still had the problem.

Rolled it forward again, same problem.

Went back to 1.15.10.  Still had the problem.

I shut down WD TV LIve (plug pulled) and the issue persisted with my computer.

For days I chased the problem. I scanned my computer with Norton Internet Security, Windows

Defender and Malwarebytes and all three came up clean.  I then ran Norton’s Repair Power


Chased numerous possible issues, disabled various Windows add-ons, changed browsers, etc.


Something effected my computer at precisely the same time I began using WD TV Live.  I

cannot say it was due to WD TV Live; but, it was a sure suspicious coincidence.

Microsoft issued numeroues Windows updates at about the same time.  Another possible add-

on issue was Microsoft Silverlight.  That I then deleted.  After days of  trial and error pursuit, I can

now say that the problem was created by one of the these three:

—The interaction between WD TV Live and Silverlight

—Microsoft Silverlight.

—A corrupt Windows update.

I believe it was a corrupt Windows update.

With Silverlight uninstalled, I’m running IE9, WD TV Live ver. 1.16.13, no Silverlight and everything is now working


The main difference is that you are now running IE9 instead of IE10.

I still run IE9 on the Win 7, along with Silverlight, and do not have the problems described here.