WD TV LIVE Problem with playback of VOB files (copied DVD)


#1

Just purchased the WD TV LIVE (I already owned and used the WD TV first generation box) and they differ in the playback of DVD movies that have been copied to a WD external 1TB hard drive.  The new version (WD TV LIVE) pauses at the end of each VOB file during playback rather than playing the movie continuously, as was done in the first generation WD TV.  Has anybody experienced this problem?  If so, is there any resolution?  As I said, the original WD TV processes these files correctly but the new version WD TV LIVE does not.  Thanks for your help.

Marty T.


#2

I have not tested this myself (and can’t test it now), but I have read elsewhere that pressing “Enter” on the first VOB will only play that VOB.  Pressing “Play” on the first VOB will play all the VOBs sequentually.  Try that and report back.  Thanks.


#3

It doesn’t matter HOW the playback is initiated (“enter” or “play”) the problem is the same in both instances.  There is a pause in the video and a quick skip in the audio at every VOB break.


#4

mtroum,

I have NOT experienced this problem. I have tried several DVD videos that have played without incident. I actually was able to have the movies play through entirely by just pressing “Enter” on the first VOB file in my VIDEO_TS folder.

I am running the most recent firmware 1.01.11

Robert Pfeifer

Pifemaster Productions

www.pifemaster.com


#5

I’ve encountered (different) problems playing VOB files. I just tried to watch the first disk of the BBC series State of Play. I’ve seen the american film and wanted to see how the series stacked up. The episodes play out of order and the first episode will not play at all via the player. Episode 3 plays first. After the credit roll, episode two starts up. After that, the player stops playing. Attempt to manually pick a different VOB to play results in the 3rd episode starting over. From my PC i can manually select VTS_02_1.VOB and the missing episode 1 starts right up. I’ve watched other series via the VOB and they’ve played properly in sequence. Since there is no way to skip chapters via
VOB playback this tarnishes my otherwise stellar opinion of the product. Any chance for a fix anytime soon? I’m using the latest firmware mentioned in the post above. Are there any unofficial solutions to this problem?


#6

I received my WD HD Live a few days ago. At first it was playing VOB files, but not conotnuously. After I did a firmware update, it will not play any VOB files at all. Even before that, it will not show a DVD menu to be able to select a subtitle. I have had a Popcorn Hour for 2 years and I thought it’s interface was user-unfriendly, but WD’s HD Live is far unfriendlier than that. It’s a shame because the actual video playback is of high quality.


#7

I have experieced exactly the same thing. My observation is that  (maybe sometimes, don’t know) it has problems with DVD’s with more than one title, it starts VTS_01_1.VOB (or maybe other) and cannot continue to play other VTS_02_1.VOB …etc. And doesn’t matter what you manualy select it starts to play only certain title. Solution for me was to rename all of those titles to .m2ts and  I removed all files around them (IFO,BUP, TS). This way only episodes stay and can be played continuously. I think if I left unused files it did not play back those m2ts subsequently.

DVD’s with one title therefore no problem (VTS_01_1.VOB,VTS_01_02.VOB …)


#8

Thanks for the info! I’ll try playing with the files. I’ll report back what I find. I hope someone in WD tech is looking a fixing the issue.


#9

I also have problem with DVD,it has glitches back and forth. DVD has theatrical and extended stream(cut),cant pick which one i want.Maybe thats the issue.


#10

Looks like two titles and again, WDTV Live decides what to play , perhaps always the biggist one, don’t know.  Rename extention of those titles to .m2ts and navigate manualy.


#11

I also just press ‘enter’ on VIDEO_TS.VOB and the dvd plays right through.

Firmware 1.01.12


#12

I am suffering the same problem making DVD playback utterly useless.

Is there anything this devices does that actually works right?


#13

I had the same problem of playing VOB files where there is few seconds between each file. 

This could be solved in more than one way.  If you want to keep the same DVD quality either make an ISO of the DVD or make an MKV file and both will play continuously (but no menu!).   Or you can encode the movie to MP4 (H264) or AVI (Xvid) with high bit rate.


#14

DrestinBlack wrote:

I am suffering the same problem making DVD playback utterly useless.

Is there anything this devices does that actually works right?

Yes, just about everything.

If you play single files there will be a pause - put them into an ISO.

Or you can try pressing play (not enter) on the video_ts folder (not in it)


#15

whattheheck wrote:

 

Yes, just about everything.

 

If you play single files there will be a pause - put them into an ISO.

 

Or you can try pressing play (not enter) on the video_ts folder (not in it)

Really? It drops network connections every 4 minutes. YouTube causes the machine to reboot.

I tried pressing Play (or enter) on the folder and on various different files within it and it’s the same thing, it randomly picks a vob and only plays that one. That’s it. I can play an ISO and it works… for 4 minutes … :frowning:

I’m a bit frustrated with it in case you couldn’t tell…


#16

Reporting back with much success. Renaming the files to .m2ts extension and deleting the extra bits worked. I was able to access the missing episode. Not the solution I’d prefer, but at least I was able to watch. Hope this gets a look in the next update.

Thanks for all the help guys!


#17

Instead of recoding etc , you could just join the vobs together and make one large flle using something like ‘join vob files tool’

http://download.cnet.com/Join-VOB-Files-Tool/3000-13631_4-10718007.html

Its quick and easy.


#18

It turns out making an ISO isn’t the fix all solution. I’ve got an ISO of Avatar: the last airbender and the WD player only plays the first episode and then quits. I’m going to try the vob merge program suggested here and see if that works for tv shows.


#19

I have the same problem with VOB files (delay).  I tried to use DVDShrink to generate an ISO file and the WD won’t play it at all.  I then tried MakeMKV with the same result, WD TV Live won’t play at all.  I haven’t tried the rename option but the docs say that it should play the ISO and the MKV.  I’m not really very happy about the product at this point.


#20

I’ve just encountered a really nasty problem:  the WDTV Live only played the file VTS_01_1.VOB in the VTS_VIDEO folder, even when I picked any other VTS_0X_1.VOB file (where X is either 2, 3, or 4) !!!

In the VIDEO_TS folder, there were all the .BUP, .IFO and .VOB files that I ripped from a DVD.  Each VOB file played perfectly on the computer with VLC or any other video player.  When I copied the folder to a USB drive and plugged it to the WDTV for play on TV, the WDTV just played the first VTS_01_1.VOB file then stopped.  When I mannually selected VTS_02_1.VOB and press ENTER or PLAY, it played the first VTS_01_1.VOB again !    The same thing occured when I selected VTS_03_1.VOB or VTS_03_1.VOB !!!

My WDTV Live has the latest firmware version 1.01.17. 

I know there are work around solutions for this, like renaming the files, put them in separate folders, make a big .ISO or .MKV file … but this is a serious bug that WD must fix asap.  It must play the .VOB that is selected, not anything else !

Very disappointed that WD could let this silly bug happen.

UPDATE

I found 2 workaround solutions for the problem:

1)  Remove all .IFO, .BUF files leaving only .VOB files in the same folder.

or

  1. Rename the starting order of each .VOB subset  from 0.  For example,  VTS_0n_1.VOB  -> VTS_0n_0.VOB,  VTS_0n_2.VOB -> VTS_0n_1.VOB, etc…   where  n is 1,2, 3. …

Either of these worked for me. But it’s clearly that there is nothing wrong with the .VOB files, just that WDTV firmwarre will become nut (pick a random VOB file and play it to death) if the .VOB files do not start wih 0 index !!!