WD TV Live Problem: Network HD


#1

I can’t access my NAS when using WD TV Live (latest firmware).  I go to Videos> Network Shares> and then it isn’t listed.  My desktop is listed, I enter in my username and password and I can stream media with no problems.  I can also acces other internet services with no problems.  Also from my computer (Win 7 Pro) I can access the NAS and play Videos in VLC with no problems.  

I’m using a D-Link DWA 125 USB Network Adapter (Ver A2), TP Link TL-WR1043ND Wireless router and WD 3.5" 1TB Elements HD.

My computer is running Windows 7 Professional. 


#2

Make sure they’re all in the same workgroup, and make sure that the master browser for that workgroup is aware of the NAS.


#3

Okay.  They’re all in the same workgroup; “Workgroup”.

How do I: " make sure that the master browser for that workgroup is aware of the NAS"?


#4

Okay.  So I ran “-nbtstat -a SWEENY-PC” and it said “- - ___MSBROWSE___- <01> Group Registered”

Does that mean the computer named SWEENY-PC, is that master browser?  It’s the computer I’m currently on and it can find the NAS in Windows Explorer, if I type “\192.168.1.1\Backup”.

Does that make the master browser “aware” of the NAS?

SWEENY-PC I turn off, and it will be off when I want to watch media streaming from the NAS.  Should I make the NAS the master browser?  It doesn’t appear after typing the net view string in command.


#5

Not necessarily.

If, on that same PC, you can issue the command

NET VIEW

without options and your NAS is listed, then yes, it’s aware of it and it should be displayed.

Are you able to use the UNC

\nasname\Backup

instead of using the IP address?  If NOT, then that could indicate an issue with NetBIOS NAME service which is required to make it work with the WDTV…


#6

I don’t know the name of the NAS/Router for use in Windows Explorer.  When I use net view the NAS is not listed.

How can I solve the netBIOS Name service issue?


#7

You’ll need to consult the documentation for the NAS to determine that.


#8

Consult the WD 3.5" 1TB Elements HD documentatio?  Okay.


#9

There is no documentation…


#10

Um, the 1TB Elements is NOT a NAS. Now I have no idea what you’re trying to do.


#11

I’ve connected my 1TB Elements to the USB port of my wireless router. Can that be access by WD TV Live?


#12

Sorry, my confusion as to what a NAS actually is. Do I need to use a router that’s on the compatibility list? http://wdc.custhelp.com/app/answers/detail/a_id/3805


#13

I have no idea.   I’ve never tried to do what you’re describing.

But if your router has the capability of acting as a NAS, then you’ll need to be looking into your router.    If it is properly configured to be a member of a Windows Workgroup, then the WDTV will see it just fine.


#14

Its not surprising its not working.

You’re trying to use a usb device as a NAS. The way they are made and their purposes and limitations are different. Sure it could work, for there have been many people that manage to get it to work, but if it doesnt work there’s very little one can even try to get it sorted out. 

Another thing you can try is to connect the elements to the computer itself, instead of to the router, and if the drive is shared like it was another folder on the computer, there’s a very good possibiilty the Live will see it. Try it that way and let us know if it worked.